
	<!DOCTYPE html>
		<html lang="en-EN">
			<head>
				<meta charset="UTF-8">
				<meta http-equiv="X-UA-Compatible" content="IE=edge">
				<meta name="viewport" content="width=device-width, initial-scale=1, maximum-scale=1.0, user-scalable=0">
				<meta name="majestic-site-verification" content="MJ12_5cbbcfc8-a04c-41c1-a9b2-c5bd10579a32">
				<meta name="pocket-site-verification" content="57301864458d86eb1a6f1e824c8097" />
				<link rel="profile" href="http://gmpg.org/xfn/11">
							<script>
	/**
	 * Cookie Helper functions
	 * @var Obj
	 * setCookie(), getCookie(),checkCookie()
	 */
	const cookieHelper={setCookie: async function(cname,cvalue,exdays){var d=new Date;d.setTime(d.getTime()+24*exdays*60*60*1e3);var expires="expires="+d.toUTCString();document.cookie=cname+"="+cvalue+";"+expires+";path=/"},getCookie:function(cname){for(var name=cname+"=",decodedCookie,ca=decodeURIComponent(document.cookie).split(";"),i=0;i<ca.length;i++){for(var c=ca[i];" "==c.charAt(0);)c=c.substring(1);if(0==c.indexOf(name))return c.substring(name.length,c.length)}return""},checkCookie:function(cname){var cnameCookie;return!!this.getCookie(cname)}};

	//cookie Name
	const cookieName = "cookieConsent";

	//Check cookie
	const x = cookieHelper.checkCookie(cookieName);

	/**
	*Removes CookieBar
	*
	* @return void
	*/
	const removeElById =function removeElById(Id){
		el = document.getElementById(Id);
		el ? el.remove() : console.log('error');
	}

	// if x = true no action needed everything is only included if there is no cookie
	if (!x) {

		var cookieBarWrapperId = "cookie-notice2";
		var cookieBarConstButton = "cons-button";
		var cookieBarStyles = "#cookie-notice2 {animation-name: fadeIn;background: rgba(48, 70, 79, 0.95);width: 100%;position: fixed;bottom: 0px;height: auto;color: #fff;z-index: 100000;text-align: center;padding:20px 10px}#cons-button {display:inline-block;margin-left:0px;with:auto;padding:10px 20px;}";
		var cookie_bar_message = "We use cookies to ensure that we give you the best experience on our website. If you continue to use this site we will assume that you are happy with it.";
		var cookieBarButtonText = "Ok";
		var cookieBarButtonId = "cons-button"
		var css = cookieBarStyles;
		var cookieBarShow = true;



		// var stylesheetFromFile = "@import url('http://example.com/big.css');";
		head = document.head || document.getElementsByTagName("head")[0],
		style = document.createElement("style");
		head.appendChild(style);
		style.type = "text/css";
		(style.styleSheet) ? style.styleSheet.cssText = css : style.appendChild(document.createTextNode(css));



		document.addEventListener("DOMContentLoaded", async function(event) {
			//was before DOMContentloaded may faster but cant be overwritten
			if(cookieBarShow){
				var cookieBar = '<div id="'+ cookieBarWrapperId  +'"><p class="cookieMessage">'+ cookie_bar_message +'</p><p><span class="btn btn-secondary" id="'+ cookieBarButtonId + '">'+ cookieBarButtonText +'</span></p></div>';

			const append = async () => {document.body.innerHTML +=(cookieBar)};

			append().then(
				() => {
				const consButton = document.getElementById(cookieBarConstButton);
				if (consButton) {
						consButton.addEventListener("click", function(){
						cookieHelper.setCookie(cookieName, true, 365);
						removeElById(cookieBarWrapperId);
						});
				}
			}
			);





			}

		});
	}


	  </script>



		<meta name='robots' content='index, follow, max-image-preview:large, max-snippet:-1, max-video-preview:-1' />

<link rel="alternate" hreflang="x-default" href="https://www.asktraders.com/analysis/snap-stock-price-slumps-22-blaming-apples-tweaks-for-revenue-drop/" />
<link rel="alternate" hreflang="en" href="https://www.asktraders.com/analysis/snap-stock-price-slumps-22-blaming-apples-tweaks-for-revenue-drop/" />

	<!-- This site is optimized with the Yoast SEO Premium plugin v17.1.2 (Yoast SEO v17.3) - https://yoast.com/wordpress/plugins/seo/ -->
	<title>Snap Stock Price Slumps 22%, Blaming Apple’s Tweaks for Revenue Drop</title>
	<meta name="description" content="Snap Inc is approaching losses of nearly 50% in the last two days. The Q3 report illuminated advertising problems with Apple’s iOS tweaks. " />
	<link rel="canonical" href="https://www.asktraders.com/analysis/snap-stock-price-slumps-22-blaming-apples-tweaks-for-revenue-drop/" />
	<meta property="og:locale" content="en_US" />
	<meta property="og:type" content="article" />
	<meta property="og:title" content="Snap Stock Price Slumps 22%, Blaming Apple’s Tweaks for Revenue Drop" />
	<meta property="og:description" content="Snap Inc is approaching losses of nearly 50% in the last two days. The Q3 report illuminated advertising problems with Apple’s iOS tweaks. " />
	<meta property="og:url" content="https://www.asktraders.com/analysis/snap-stock-price-slumps-22-blaming-apples-tweaks-for-revenue-drop/" />
	<meta property="og:site_name" content="AskTraders.com" />
	<meta property="article:publisher" content="https://www.facebook.com/asktraderscom" />
	<meta property="og:image" content="https://www.asktraders.com/wp-content/uploads/2021/09/SNAP-150x150-1.png" />
	<meta property="og:image:width" content="150" />
	<meta property="og:image:height" content="150" />
	<meta name="twitter:card" content="summary_large_image" />
	<meta name="twitter:label1" content="Est. reading time" />
	<meta name="twitter:data1" content="2 minutes" />
	<script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"Organization","@id":"https://www.asktraders.com/#organization","name":"AskTraders","url":"https://www.asktraders.com/","sameAs":["https://www.facebook.com/asktraderscom"],"logo":{"@type":"ImageObject","@id":"https://www.asktraders.com/#logo","inLanguage":"en-EN","url":"https://www.asktraders.com/wp-content/uploads/2019/05/asktraders-logo-tm-white.png","contentUrl":"https://www.asktraders.com/wp-content/uploads/2019/05/asktraders-logo-tm-white.png","width":232,"height":38,"caption":"AskTraders"},"image":{"@id":"https://www.asktraders.com/#logo"}},{"@type":"WebSite","@id":"https://www.asktraders.com/#website","url":"https://www.asktraders.com/","name":"AskTraders.com","description":"","publisher":{"@id":"https://www.asktraders.com/#organization"},"inLanguage":"en-EN"},{"@type":"ImageObject","@id":"https://www.asktraders.com/analysis/snap-stock-price-slumps-22-blaming-apples-tweaks-for-revenue-drop/#primaryimage","inLanguage":"en-EN","url":"https://www.asktraders.com/wp-content/uploads/2021/09/SNAP-150x150-1.png","contentUrl":"https://www.asktraders.com/wp-content/uploads/2021/09/SNAP-150x150-1.png","width":150,"height":150,"caption":"SNAP logo"},{"@type":"WebPage","@id":"https://www.asktraders.com/analysis/snap-stock-price-slumps-22-blaming-apples-tweaks-for-revenue-drop/#webpage","url":"https://www.asktraders.com/analysis/snap-stock-price-slumps-22-blaming-apples-tweaks-for-revenue-drop/","name":"Snap Stock Price Slumps 22%, Blaming Apple\u2019s Tweaks for Revenue Drop","isPartOf":{"@id":"https://www.asktraders.com/#website"},"primaryImageOfPage":{"@id":"https://www.asktraders.com/analysis/snap-stock-price-slumps-22-blaming-apples-tweaks-for-revenue-drop/#primaryimage"},"datePublished":"2021-10-22T15:43:26+00:00","dateModified":"2021-10-22T15:43:26+00:00","description":"Snap Inc is approaching losses of nearly 50% in the last two days. The Q3 report illuminated advertising problems with Apple\u2019s iOS tweaks.\u00a0","breadcrumb":{"@id":"https://www.asktraders.com/analysis/snap-stock-price-slumps-22-blaming-apples-tweaks-for-revenue-drop/#breadcrumb"},"inLanguage":"en-EN","potentialAction":[{"@type":"ReadAction","target":["https://www.asktraders.com/analysis/snap-stock-price-slumps-22-blaming-apples-tweaks-for-revenue-drop/"]}]},{"@type":"BreadcrumbList","@id":"https://www.asktraders.com/analysis/snap-stock-price-slumps-22-blaming-apples-tweaks-for-revenue-drop/#breadcrumb","itemListElement":[{"@type":"ListItem","position":1,"name":"Home","item":"https://www.asktraders.com/"},{"@type":"ListItem","position":2,"name":"analysis","item":"https://www.asktraders.com/Market Analysis/"},{"@type":"ListItem","position":3,"name":"Snap Stock Price Slumps 22%, Blaming Apple\u2019s Tweaks for Revenue Drop"}]},{"@type":["Article","NewsArticle"],"@id":"https://www.asktraders.com/analysis/snap-stock-price-slumps-22-blaming-apples-tweaks-for-revenue-drop/#article","isPartOf":{"@id":"https://www.asktraders.com/analysis/snap-stock-price-slumps-22-blaming-apples-tweaks-for-revenue-drop/#webpage"},"author":{"@id":"https://www.asktraders.com/#/schema/person/5fea7ae045c466bcd716f14c1e63a4f4"},"headline":"Snap Stock Price Slumps 22%, Blaming Apple\u2019s Tweaks for Revenue Drop","datePublished":"2021-10-22T15:43:26+00:00","dateModified":"2021-10-22T15:43:26+00:00","mainEntityOfPage":{"@id":"https://www.asktraders.com/analysis/snap-stock-price-slumps-22-blaming-apples-tweaks-for-revenue-drop/#webpage"},"wordCount":263,"commentCount":0,"publisher":{"@id":"https://www.asktraders.com/#organization"},"image":{"@id":"https://www.asktraders.com/analysis/snap-stock-price-slumps-22-blaming-apples-tweaks-for-revenue-drop/#primaryimage"},"thumbnailUrl":"https://www.asktraders.com/wp-content/uploads/2021/09/SNAP-150x150-1.png","inLanguage":"en-EN","potentialAction":[{"@type":"CommentAction","name":"Comment","target":["https://www.asktraders.com/analysis/snap-stock-price-slumps-22-blaming-apples-tweaks-for-revenue-drop/#respond"]}],"copyrightYear":"2021","copyrightHolder":{"@id":"https://www.asktraders.com/#organization"}},{"@type":"Person","@id":"https://www.asktraders.com/#/schema/person/5fea7ae045c466bcd716f14c1e63a4f4","name":"Nigel Frith","image":{"@type":"ImageObject","@id":"https://www.asktraders.com/#personlogo","inLanguage":"en-EN","url":"https://secure.gravatar.com/avatar/d7e9bfcc31d03448505442db86db2f88?s=96&d=mm&r=g","contentUrl":"https://secure.gravatar.com/avatar/d7e9bfcc31d03448505442db86db2f88?s=96&d=mm&r=g","caption":"Nigel Frith"},"description":"Nigel has an understanding of market fundamentals gained through over 10 years\u2019 experience in the financial markets. He provides up to the minute analysis and insight into the financial markets, as well as on the broader economy and monetary policy in the UK, US, Europe and Asia.","sameAs":["https://www.asktraders.com","https://www.facebook.com/nigel.frith.trader","https://www.linkedin.com/in/nigelfrith/"]}]}</script>
	<!-- / Yoast SEO Premium plugin. -->


<link rel='dns-prefetch' href='//www.asktraders.com' />
<link rel='dns-prefetch' href='//a.omappapi.com' />
<link rel='dns-prefetch' href='//www.googletagmanager.com' />
<link rel='dns-prefetch' href='//www.google-analytics.com' />
<link rel='dns-prefetch' href='//9112644.fls.doubleclick.net' />
<link rel='dns-prefetch' href='//a.mgid.com' />
<link rel='dns-prefetch' href='//code.jquery.com' />
<link rel='dns-prefetch' href='//connect.facebook.net' />
<link rel='dns-prefetch' href='//510001426.collect.igodigital.com' />
<link rel='dns-prefetch' href='//adservice.google.com' />
<link rel='dns-prefetch' href='//tau.collect.igodigital.com' />
<link rel='dns-prefetch' href='//www.facebook.com' />
<link rel='dns-prefetch' href='//adservice.google.ca' />
<link rel='dns-prefetch' href='//static.hotjar.com' />
<link rel='dns-prefetch' href='//widget.intercom.io' />
<link rel='dns-prefetch' href='//js.intercomcdn.com' />
<link rel='dns-prefetch' href='//script.hotjar.com' />
<link rel='dns-prefetch' href='//api-iam.intercom.io' />
<link rel='dns-prefetch' href='//vars.hotjar.com' />
<link rel='dns-prefetch' href='//in.hotjar.com' />
<link rel="alternate" type="application/rss+xml" title="AskTraders.com &raquo; Feed" href="https://www.asktraders.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="AskTraders.com &raquo; Comments Feed" href="https://www.asktraders.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="AskTraders.com &raquo; Snap Stock Price Slumps 22%, Blaming Apple’s Tweaks for Revenue Drop Comments Feed" href="https://www.asktraders.com/analysis/snap-stock-price-slumps-22-blaming-apples-tweaks-for-revenue-drop/feed/" />
<link rel="preload" as="image" href="https://www.asktraders.com/wp-content/uploads/2021/03/ATNewsbannermobile.png" ><link rel='stylesheet' id='wpml-legacy-horizontal-list-0-css'  href='//www.asktraders.com/wp-content/plugins/sitepress-multilingual-cms/templates/language-switchers/legacy-list-horizontal/style.min.css?ver=1' type='text/css' media='all' />
<link data-minify="1" rel='stylesheet' id='spx_newsletter_css-css'  href='https://www.asktraders.com/wp-content/cache/min/1/wp-content/plugins/spx-newsletters/assets/css/newsletter.css?ver=1634635969' type='text/css' media='all' />
<link data-minify="1" rel='stylesheet' id='plugin-name-frontend-css-css'  href='https://www.asktraders.com/wp-content/cache/min/1/wp-content/plugins/wsam-live-search/assets/public/css/frontend.css?ver=1634635969' type='text/css' media='all' />
<link rel='stylesheet' id='search-live-style-css'  href='https://www.asktraders.com/wp-content/themes/asktraders/search/search.css?ver=1.0.3' type='text/css' media='all' />
<link data-minify="1" rel='stylesheet' id='theme-css-css'  href='https://www.asktraders.com/wp-content/cache/min/1/wp-content/themes/asktraders/build/bundle.85da8529.css?ver=1634635969' type='text/css' media='all' />
<style id='rocket-lazyload-inline-css' type='text/css'>
.rll-youtube-player{position:relative;padding-bottom:56.23%;height:0;overflow:hidden;max-width:100%;}.rll-youtube-player iframe{position:absolute;top:0;left:0;width:100%;height:100%;z-index:100;background:0 0}.rll-youtube-player img{bottom:0;display:block;left:0;margin:auto;max-width:100%;width:100%;position:absolute;right:0;top:0;border:none;height:auto;cursor:pointer;-webkit-transition:.4s all;-moz-transition:.4s all;transition:.4s all}.rll-youtube-player img:hover{-webkit-filter:brightness(75%)}.rll-youtube-player .play{height:72px;width:72px;left:50%;top:50%;margin-left:-36px;margin-top:-36px;position:absolute;background:url(https://www.asktraders.com/wp-content/plugins/wp-rocket/assets/img/youtube.png) no-repeat;cursor:pointer}
</style>
<script data-minify="1" type='text/javascript' src='https://www.asktraders.com/wp-content/cache/min/1/wp-content/themes/asktraders/js/at-tracking.js?ver=1634635969' id='at-tracking-js' defer></script>
<script type='text/javascript' src='https://www.asktraders.com/wp-includes/js/jquery/jquery.min.js?ver=3.5.1' id='jquery-core-js' defer></script>
<script type='text/javascript' src='https://www.asktraders.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=3.3.2' id='jquery-migrate-js' defer></script>
<script type='text/javascript' src='https://www.asktraders.com/wp-content/plugins/wsam-analytics/assets/js/web-vitals.min.js?ver=0.1' id='wsam-analytics-web-vitals-js' defer></script>
<script data-minify="1" type='text/javascript' src='https://www.asktraders.com/wp-content/cache/min/1/wp-content/themes/asktraders/search/search.js?ver=1634635969' id='search-live-script-js' defer></script>
<link rel="https://api.w.org/" href="https://www.asktraders.com/wp-json/" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.asktraders.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.asktraders.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 5.7.2" />
<link rel='shortlink' href='https://www.asktraders.com/?p=129245' />
<!-- Google Tag Manager --><script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src='https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);})(window,document,'script','dataLayer','GTM-PLCSCD7');</script><!-- End Google Tag Manager --><meta name="generator" content="WPML ver:4.4.10 stt:69,5,1,79,3,27,78,80,63,75,76,2;" />

<link rel="preload" as="font" href="https://www.asktraders.com/wp-content/themes/asktraders/design/fonts/GothamMedium.woff2" crossorigin>
<link rel="preload" as="font" href="https://www.asktraders.com/wp-content/themes/asktraders/design/fonts/HelveticaNeue.woff2" crossorigin>      <meta name="onesignal" content="wordpress-plugin"/>
            <script>

      window.OneSignal = window.OneSignal || [];

      OneSignal.push( function() {
        OneSignal.SERVICE_WORKER_UPDATER_PATH = "OneSignalSDKUpdaterWorker.js.php";
                      OneSignal.SERVICE_WORKER_PATH = "OneSignalSDKWorker.js.php";
                      OneSignal.SERVICE_WORKER_PARAM = { scope: "/" };
        OneSignal.setDefaultNotificationUrl("https://www.asktraders.com");
        var oneSignal_options = {};
        window._oneSignalInitOptions = oneSignal_options;

        oneSignal_options['wordpress'] = true;
oneSignal_options['appId'] = '84ad5f98-8169-4cdf-b4bc-4ee995bf338c';
oneSignal_options['allowLocalhostAsSecureOrigin'] = true;
oneSignal_options['welcomeNotification'] = { };
oneSignal_options['welcomeNotification']['title'] = "";
oneSignal_options['welcomeNotification']['message'] = "Thanks For Subscribing To Our Market News!";
oneSignal_options['path'] = "https://www.asktraders.com/wp-content/plugins/onesignal-free-web-push-notifications/sdk_files/";
oneSignal_options['safari_web_id'] = "web.onesignal.auto.28671d66-3da8-4a50-bcc4-1b29e015670b";
oneSignal_options['promptOptions'] = { };
oneSignal_options['promptOptions']['acceptButtonText'] = "Sign Up";
oneSignal_options['promptOptions']['siteName'] = "https://www.asktraders.com";
oneSignal_options['notifyButton'] = { };
oneSignal_options['notifyButton']['enable'] = true;
oneSignal_options['notifyButton']['position'] = 'bottom-right';
oneSignal_options['notifyButton']['theme'] = 'default';
oneSignal_options['notifyButton']['size'] = 'medium';
oneSignal_options['notifyButton']['showCredit'] = false;
                OneSignal.init(window._oneSignalInitOptions);
                OneSignal.showSlidedownPrompt();      });

      function documentInitOneSignal() {
        var oneSignal_elements = document.getElementsByClassName("OneSignal-prompt");

        var oneSignalLinkClickHandler = function(event) { OneSignal.push(['registerForPushNotifications']); event.preventDefault(); };        for(var i = 0; i < oneSignal_elements.length; i++)
          oneSignal_elements[i].addEventListener('click', oneSignalLinkClickHandler, false);
      }

      if (document.readyState === 'complete') {
           documentInitOneSignal();
      }
      else {
           window.addEventListener("load", function(event){
               documentInitOneSignal();
          });
      }
    </script>
<link rel="icon" href="https://www.asktraders.com/wp-content/uploads/2020/04/cropped-Group-217-32x32.png" sizes="32x32" />
<link rel="icon" href="https://www.asktraders.com/wp-content/uploads/2020/04/cropped-Group-217-192x192.png" sizes="192x192" />
<link rel="apple-touch-icon" href="https://www.asktraders.com/wp-content/uploads/2020/04/cropped-Group-217-180x180.png" />
<meta name="msapplication-TileImage" content="https://www.asktraders.com/wp-content/uploads/2020/04/cropped-Group-217-270x270.png" />
		<style type="text/css" id="wp-custom-css">
			header {
	min-height:60px;
}

@font-face {
  font-family: "Gotham";
  src: url("/wp-content/themes/asktraders/design/fonts/GothamMedium.woff2") format("woff2"), url("/wp-content/themes/asktraders/design/fonts/GothamMedium.woff") format("woff");
  font-weight: 500;
  font-style: normal;
  font-display: optional;
}

		</style>
		<style>
.ai-viewports                 {--ai: 1;}
.ai-viewport-3                { display: none !important;}
.ai-viewport-2                { display: none !important;}
.ai-viewport-1                { display: inherit !important;}
.ai-viewport-0                { display: none !important;}
@media (min-width: 768px) and (max-width: 979px) {
.ai-viewport-1                { display: none !important;}
.ai-viewport-2                { display: inherit !important;}
}
@media (max-width: 767px) {
.ai-viewport-1                { display: none !important;}
.ai-viewport-3                { display: inherit !important;}
}
.ai-rotate {position: relative;}
.ai-rotate-hidden {visibility: hidden;}
.ai-rotate-hidden-2 {position: absolute; top: 0; left: 0; width: 100%; height: 100%;}
.ai-list-data, .ai-ip-data, .ai-fallback, .ai-list-block {visibility: hidden; position: absolute; width: 50%; height: 1px; z-index: -9999;}
</style>
<noscript><style id="rocket-lazyload-nojs-css">.rll-youtube-player, [data-lazy-src]{display:none !important;}</style></noscript>			
<script>(window.BOOMR_mq=window.BOOMR_mq||[]).push(["addVar",{"rua.upush":"false","rua.cpush":"false","rua.upre":"false","rua.cpre":"false","rua.uprl":"false","rua.cprl":"false","rua.cprf":"false","rua.trans":"","rua.cook":"false","rua.ims":"false","rua.ufprl":"false","rua.cfprl":"false","rua.isuxp":"false","rua.texp":"norulematch"}]);</script>
<script>!function(){function o(n,i){if(n&&i)for(var r in i)i.hasOwnProperty(r)&&(void 0===n[r]?n[r]=i[r]:n[r].constructor===Object&&i[r].constructor===Object?o(n[r],i[r]):n[r]=i[r])}try{var n=decodeURIComponent("%7B%22Akamai%22%3A%20%7B%22enabled%22%3Afalse%7D%2C%20%22secure_cookie%22%3A%20true%7D");if(n.length>0&&window.JSON&&"function"==typeof window.JSON.parse){var i=JSON.parse(n);void 0!==window.BOOMR_config?o(window.BOOMR_config,i):window.BOOMR_config=i}}catch(r){window.console&&"function"==typeof window.console.error&&console.error("mPulse: Could not parse configuration",r)}}();</script>
                              <script>!function(e){var n="https://s.go-mpulse.net/boomerang/";if("False"=="True")e.BOOMR_config=e.BOOMR_config||{},e.BOOMR_config.PageParams=e.BOOMR_config.PageParams||{},e.BOOMR_config.PageParams.pci=!0,n="https://s2.go-mpulse.net/boomerang/";if(window.BOOMR_API_key="PANQM-J4FGE-TRRW9-SKJWE-BPS2E",function(){function e(){if(!o){var e=document.createElement("script");e.id="boomr-scr-as",e.src=window.BOOMR.url,e.async=!0,i.parentNode.appendChild(e),o=!0}}function t(e){o=!0;var n,t,a,r,d=document,O=window;if(window.BOOMR.snippetMethod=e?"if":"i",t=function(e,n){var t=d.createElement("script");t.id=n||"boomr-if-as",t.src=window.BOOMR.url,BOOMR_lstart=(new Date).getTime(),e=e||d.body,e.appendChild(t)},!window.addEventListener&&window.attachEvent&&navigator.userAgent.match(/MSIE [67]\./))return window.BOOMR.snippetMethod="s",void t(i.parentNode,"boomr-async");a=document.createElement("IFRAME"),a.src="about:blank",a.title="",a.role="presentation",a.loading="eager",r=(a.frameElement||a).style,r.width=0,r.height=0,r.border=0,r.display="none",i.parentNode.appendChild(a);try{O=a.contentWindow,d=O.document.open()}catch(_){n=document.domain,a.src="javascript:var d=document.open();d.domain='"+n+"';void(0);",O=a.contentWindow,d=O.document.open()}if(n)d._boomrl=function(){this.domain=n,t()},d.write("<bo"+"dy onload='document._boomrl();'>");else if(O._boomrl=function(){t()},O.addEventListener)O.addEventListener("load",O._boomrl,!1);else if(O.attachEvent)O.attachEvent("onload",O._boomrl);d.close()}function a(e){window.BOOMR_onload=e&&e.timeStamp||(new Date).getTime()}if(!window.BOOMR||!window.BOOMR.version&&!window.BOOMR.snippetExecuted){window.BOOMR=window.BOOMR||{},window.BOOMR.snippetStart=(new Date).getTime(),window.BOOMR.snippetExecuted=!0,window.BOOMR.snippetVersion=12,window.BOOMR.url=n+"PANQM-J4FGE-TRRW9-SKJWE-BPS2E";var i=document.currentScript||document.getElementsByTagName("script")[0],o=!1,r=document.createElement("link");if(r.relList&&"function"==typeof r.relList.supports&&r.relList.supports("preload")&&"as"in r)window.BOOMR.snippetMethod="p",r.href=window.BOOMR.url,r.rel="preload",r.as="script",r.addEventListener("load",e),r.addEventListener("error",function(){t(!0)}),setTimeout(function(){if(!o)t(!0)},3e3),BOOMR_lstart=(new Date).getTime(),i.parentNode.appendChild(r);else t(!1);if(window.addEventListener)window.addEventListener("load",a,!1);else if(window.attachEvent)window.attachEvent("onload",a)}}(),"".length>0)if(e&&"performance"in e&&e.performance&&"function"==typeof e.performance.setResourceTimingBufferSize)e.performance.setResourceTimingBufferSize();!function(){if(BOOMR=e.BOOMR||{},BOOMR.plugins=BOOMR.plugins||{},!BOOMR.plugins.AK){var n=""=="true"?1:0,t="",a="nml5ubfygnsvqyls4tka-f-06bdf98b8-clientnsv4-s.akamaihd.net",i="false"=="true"?2:1,o={"ak.v":"32","ak.cp":"1109222","ak.ai":parseInt("656774",10),"ak.ol":"0","ak.cr":1,"ak.ipv":4,"ak.proto":"http/1.1","ak.rid":"1bea50","ak.r":19860,"ak.a2":n,"ak.m":"","ak.n":"essl","ak.bpcip":"107.23.218.0","ak.cport":60760,"ak.gh":"184.51.101.56","ak.quicv":"","ak.tlsv":"tls1.2","ak.0rtt":"","ak.csrc":"-","ak.acc":"reno","ak.t":"1634919636","ak.ak":"hOBiQwZUYzCg5VSAfCLimQ==byV8/8IAweIyDi7Lk6IPp9WWH+/7QYJnZ24IN8KI+IoeiQYAU7uWWIk/4rJET0lai1xBzDKKEAAg2RVFZS4HpzKxN29jXGngKdhoLxpqn4Z8grGVuiiFuv+NlBLcpIeV1pQOFdmGn1mHGJAvcrL4tXSu0mh8NWO5YqJk8Nlal4mpPfWuzApj3jQm6WMaXfadhic7ebAGuAOV8WzTUjxwfDyLocJSxo51WD0bC1dObve71Wlf7lZ/xJpr698w+D7ZGZvi1D3FKDhRwR0elPxSbyHj34s9SNtz6qTH+S7NoSQFfLvm3xM+PIRv6yONIKRsawYvjrkcwEtfsAbjF1H1grCCczU60oc6DtGU+NfLP+Xk406YyW9ibeOhysv9gm/IbZrizy/GGIjyVBjTDeFVvaRW4opSeNERyIM/VdJIYic=","ak.pv":"19","ak.dpoabenc":"","ak.tf":i};if(""!==t)o["ak.ruds"]=t;var r={i:!1,av:function(n){var t="http.initiator";if(n&&(!n[t]||"spa_hard"===n[t]))o["ak.feo"]=void 0!==e.aFeoApplied?1:0,BOOMR.addVar(o)},rv:function(){var e=["ak.bpcip","ak.cport","ak.cr","ak.csrc","ak.gh","ak.ipv","ak.m","ak.n","ak.ol","ak.proto","ak.quicv","ak.tlsv","ak.0rtt","ak.r","ak.acc","ak.t","ak.tf"];BOOMR.removeVar(e)}};BOOMR.plugins.AK={akVars:o,akDNSPreFetchDomain:a,init:function(){if(!r.i){var e=BOOMR.subscribe;e("before_beacon",r.av,null,null),e("onbeacon",r.rv,null,null),r.i=!0}return this},is_complete:function(){return!0}}}}()}(window);</script></head>

			<body data-spy="scroll" data-target=".nav.flex-column" data-offset="50" data-pagetype="news"
																																   class="news-template-default single single-news postid-129245 wp-custom-logo snap-stock-price-slumps-22-blaming-apples-tweaks-for-revenue-drop"																																	>
				<header>
					<nav class="navbar navbar-expand-lg
										">
						<a class="navbar-brand at-logo" href="https://www.asktraders.com">

											<svg fill="none" viewBox="0 0 134 21" xmlns="http://www.w3.org/2000/svg">
						<g clip-path="url(#a)" fill="#555">
							<path d="m9.7978 20.664-0.77898-3.4193h-4.1509l-0.74805 3.4193h-4.1199l4.868-20.356h4.3055l4.9945 20.356h-4.3702zm-1.4061-6.5635c-0.4359-1.9531-0.87461-3.876-1.1868-5.8593-0.12374-0.88577-0.25029-1.8018-0.3431-2.6848-0.18842 2.8691-0.7818 5.708-1.3724 8.5469l2.9022-0.0027z"/>
							<path d="m23.527 4.9159c-0.8437-0.70147-1.8111-1.3122-2.9641-1.3122-1.2177 0-2.0586 0.795-2.0586 1.9834 0 3.5101 6.2432 3.4468 6.2432 9.1246 0 3.5101-2.1542 6.2884-5.931 6.2884-1.2754 0.0139-2.5256-0.3474-3.5884-1.037v-3.8512c0.9364 0.6107 1.9039 1.1003 3.0597 1.1003 1.4061 0 2.4326-0.8555 2.4326-2.2584 0.0053-0.3573-0.0695-0.7113-0.2194-1.0371-0.374-0.762-1.5298-1.4359-2.216-1.8926-2.3398-1.5872-3.8387-3.0534-3.8387-6.0134 0-3.202 1.9039-6.0106 5.4304-6.0106 1.2883-0.017237 2.5554 0.32123 3.6559 0.97655l-0.0056 3.9392z"/>
							<path d="m34.363 20.665-3.8387-10.349v10.349h-4.1199v-20.356h4.1199v9.0943l3.4646-9.0971h4.2184l-3.8443 9.4024 4.3055 10.957h-4.3055z"/>
							<path d="m46.495 4.0303v16.634h-4.1199v-16.634h-3.2144v-3.7247h10.546v3.7247h-3.2116z"/>
							<path d="m58.832 20.664-3.6559-9.3721v9.3721h-4.1143v-20.356h4.463c1.5299 0 3.2144 0.12104 4.5249 0.97656 1.6536 1.0673 2.4663 3.0507 2.4663 4.9515 0 2.319-0.9365 3.9667-2.9641 5.1881l3.6194 9.2484-4.3393-0.0083zm-3.6531-11.587c0.2278 0.02536 0.457 0.03547 0.6862 0.03026 1.7773 0 2.6519-1.1911 2.6519-2.8389s-0.748-2.7784-2.5591-2.7784h-0.7818l0.0028 5.587z"/>
							<path d="m73.725 20.664-0.779-3.4193h-4.1508l-0.7396 3.4193h-4.1284l4.868-20.356h4.3055l4.9945 20.356h-4.3702zm-1.4061-6.5635c-0.4359-1.9531-0.8746-3.876-1.1868-5.8593-0.1237-0.88577-0.2502-1.8018-0.343-2.6848-0.1885 2.8691-0.7818 5.708-1.3724 8.5469l2.9022-0.0027z"/>
							<path d="m83.264 0.30566c1.5299 0 2.8123 0.060519 4.2184 0.70147 3.7121 1.6505 4.7808 5.9528 4.7808 9.584 0 5.5017-2.1233 10.074-8.4367 10.074h-4.0243v-20.356l3.4618-0.002751zm0.7818 16.634c3.2763 0.0302 4.0862-3.8512 4.0862-6.3793 0-2.0136-0.4668-4.6406-2.1204-5.9831-0.6553-0.55017-1.2486-0.67121-2.0923-0.70147v13.064h0.1265z"/>
							<path d="m94.064 20.664v-20.356h8.2675v3.7824h-4.1475v4.4014h3.6555v3.8512h-3.6555v4.5664h4.2185v3.7549h-8.3385z"/>
							<path d="m112.29 20.664-3.656-9.3721v9.3721h-4.114v-20.356h4.463c1.529 0 3.214 0.12104 4.524 0.97656 1.654 1.0673 2.467 3.0507 2.467 4.9515 0 2.319-0.937 3.9667-2.964 5.1881l3.616 9.2401h-4.336zm-3.65-11.587c0.227 0.02536 0.457 0.03547 0.686 0.03026 1.777 0 2.652-1.1911 2.652-2.8389s-0.748-2.7784-2.559-2.7784h-0.779v5.587z"/>
							<path d="m126.36 4.9159c-0.843-0.70147-1.811-1.3122-2.964-1.3122-1.217 0-2.058 0.795-2.058 1.9834 0 3.5101 6.24 3.4496 6.24 9.1273 0 3.5101-2.154 6.2885-5.931 6.2885-1.275 0.0138-2.525-0.3475-3.588-1.0371v-3.8512c0.936 0.6107 1.904 1.1004 3.059 1.1004 1.406 0 2.433-0.8555 2.433-2.2585 5e-3 -0.3572-0.07-0.7112-0.219-1.0371-0.374-0.7619-1.53-1.4359-2.216-1.8925-2.34-1.5873-3.842-3.0535-3.842-6.0134 0-3.2047 1.91-6.0134 5.433-6.0134 1.289-0.017237 2.556 0.32123 3.656 0.97655l-3e-3 3.9392z"/>
							<path d="m129.08 5.4662v-3.9282h-0.843v-0.55017h2.325v0.55017h-0.843v3.9282h-0.639z"/>
							<path d="m130.85 5.466 0.393-4.4894h0.563l0.621 3.1085 0.639-3.1085h0.54l0.399 4.4894h-0.563l-0.196-3.147-0.614 3.147h-0.419l-0.599-3.147-0.185 3.147h-0.579z"/>
						</g>
						<defs><clipPath id="a"><rect width="134" height="21" fill="#fff"/></clipPath></defs>
					</svg>
							</a>

			<div class="collapse navbar-collapse navbar_global modal fade2" id="navbarSupportedContent" role="dialog">

													<ul class="navbar-nav">
													<li class="nav-item dropdown">
								<a class="at-navbar-brand-modal" href="#">
									<svg width="134" height="21"  fill="none" viewBox="0 0 134 21" xmlns="http://www.w3.org/2000/svg"><g clip-path="url(#b)" fill="#555"><path d="m9.7978 20.664-0.77898-3.4193h-4.1509l-0.74805 3.4193h-4.1199l4.868-20.356h4.3055l4.9945 20.356h-4.3702zm-1.4061-6.5635c-0.4359-1.9531-0.87461-3.876-1.1868-5.8593-0.12374-0.88577-0.25029-1.8018-0.3431-2.6848-0.18842 2.8691-0.7818 5.708-1.3724 8.5469l2.9022-0.0027z"/><path d="m23.527 4.9159c-0.8437-0.70147-1.8111-1.3122-2.9641-1.3122-1.2177 0-2.0586 0.795-2.0586 1.9834 0 3.5101 6.2432 3.4468 6.2432 9.1246 0 3.5101-2.1542 6.2884-5.931 6.2884-1.2754 0.0139-2.5256-0.3474-3.5884-1.037v-3.8512c0.9364 0.6107 1.9039 1.1003 3.0597 1.1003 1.4061 0 2.4326-0.8555 2.4326-2.2584 0.0053-0.3573-0.0695-0.7113-0.2194-1.0371-0.374-0.762-1.5298-1.4359-2.216-1.8926-2.3398-1.5872-3.8387-3.0534-3.8387-6.0134 0-3.202 1.9039-6.0106 5.4304-6.0106 1.2883-0.017237 2.5554 0.32123 3.6559 0.97655l-0.0056 3.9392z"/><path d="m34.363 20.665-3.8387-10.349v10.349h-4.1199v-20.356h4.1199v9.0943l3.4646-9.0971h4.2184l-3.8443 9.4024 4.3055 10.957h-4.3055z"/><path d="m46.495 4.0303v16.634h-4.1199v-16.634h-3.2144v-3.7247h10.546v3.7247h-3.2116z"/><path d="m58.832 20.664-3.6559-9.3721v9.3721h-4.1143v-20.356h4.463c1.5299 0 3.2144 0.12104 4.5249 0.97656 1.6536 1.0673 2.4663 3.0507 2.4663 4.9515 0 2.319-0.9365 3.9667-2.9641 5.1881l3.6194 9.2484-4.3393-0.0083zm-3.6531-11.587c0.2278 0.02536 0.457 0.03547 0.6862 0.03026 1.7773 0 2.6519-1.1911 2.6519-2.8389s-0.748-2.7784-2.5591-2.7784h-0.7818l0.0028 5.587z"/><path d="m73.725 20.664-0.779-3.4193h-4.1508l-0.7396 3.4193h-4.1284l4.868-20.356h4.3055l4.9945 20.356h-4.3702zm-1.4061-6.5635c-0.4359-1.9531-0.8746-3.876-1.1868-5.8593-0.1237-0.88577-0.2502-1.8018-0.343-2.6848-0.1885 2.8691-0.7818 5.708-1.3724 8.5469l2.9022-0.0027z"/><path d="m83.264 0.30566c1.5299 0 2.8123 0.060519 4.2184 0.70147 3.7121 1.6505 4.7808 5.9528 4.7808 9.584 0 5.5017-2.1233 10.074-8.4367 10.074h-4.0243v-20.356l3.4618-0.002751zm0.7818 16.634c3.2763 0.0302 4.0862-3.8512 4.0862-6.3793 0-2.0136-0.4668-4.6406-2.1204-5.9831-0.6553-0.55017-1.2486-0.67121-2.0923-0.70147v13.064h0.1265z"/><path d="m94.064 20.664v-20.356h8.2675v3.7824h-4.1475v4.4014h3.6555v3.8512h-3.6555v4.5664h4.2185v3.7549h-8.3385z"/><path d="m112.29 20.664-3.656-9.3721v9.3721h-4.114v-20.356h4.463c1.529 0 3.214 0.12104 4.524 0.97656 1.654 1.0673 2.467 3.0507 2.467 4.9515 0 2.319-0.937 3.9667-2.964 5.1881l3.616 9.2401h-4.336zm-3.65-11.587c0.227 0.02536 0.457 0.03547 0.686 0.03026 1.777 0 2.652-1.1911 2.652-2.8389s-0.748-2.7784-2.559-2.7784h-0.779v5.587z"/><path d="m126.36 4.9159c-0.843-0.70147-1.811-1.3122-2.964-1.3122-1.217 0-2.058 0.795-2.058 1.9834 0 3.5101 6.24 3.4496 6.24 9.1273 0 3.5101-2.154 6.2885-5.931 6.2885-1.275 0.0138-2.525-0.3475-3.588-1.0371v-3.8512c0.936 0.6107 1.904 1.1004 3.059 1.1004 1.406 0 2.433-0.8555 2.433-2.2585 5e-3 -0.3572-0.07-0.7112-0.219-1.0371-0.374-0.7619-1.53-1.4359-2.216-1.8925-2.34-1.5873-3.842-3.0535-3.842-6.0134 0-3.2047 1.91-6.0134 5.433-6.0134 1.289-0.017237 2.556 0.32123 3.656 0.97655l-3e-3 3.9392z"/><path d="m129.08 5.4662v-3.9282h-0.843v-0.55017h2.325v0.55017h-0.843v3.9282h-0.639z"/><path d="m130.85 5.466 0.393-4.4894h0.563l0.621 3.1085 0.639-3.1085h0.54l0.399 4.4894h-0.563l-0.196-3.147-0.614 3.147h-0.419l-0.599-3.147-0.185 3.147h-0.579z"/></g><defs><clipPath id="a"><rect width="134" height="21" fill="#fff"/></clipPath></defs></svg>
								</a>
								<a class="current-flag nav-link dropdown-toggle" href="#" role="button" data-toggle="dropdown" aria-haspopup="true" aria-expanded="false" >
	<img src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%2022%2022'%3E%3C/svg%3E" width="22" height="22" alt="English" data-lazy-src="https://www.asktraders.com/wp-content/uploads/flags/united-kingdom.png"><noscript><img src="https://www.asktraders.com/wp-content/uploads/flags/united-kingdom.png" width="22" height="22" alt="English"></noscript>
	English (en)</a>

<div class="dropdown-menu" aria-labelledby="navbarDropdown">


							<a class="dropdown-item" href="https://www.asktraders.com/analysis/snap-stock-price-slumps-22-blaming-apples-tweaks-for-revenue-drop/">
			<img src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%2022%2022'%3E%3C/svg%3E" width="22" height="22" alt="English" data-lazy-src="https://www.asktraders.com/wp-content/uploads/flags/united-kingdom.png"><noscript><img src="https://www.asktraders.com/wp-content/uploads/flags/united-kingdom.png" width="22" height="22" alt="English"></noscript>
			English							<svg class="at-selected" width="24" height="24" viewBox="0 0 24 24" fill="none" xmlns="http://www.w3.org/2000/svg"><path d="M20 6L9 17L4 12" stroke="#15C67F" stroke-width="2" stroke-linecap="round" stroke-linejoin="round"/></svg>
					</a>
					</div>

							</li>
											</ul>

				
				<ul id="menu-main-menu" class="navbar-nav main-top-nav"><li class='nav-item dropdown'><a class="nav-link dropdown-toggle"  href="#" role="button" data-toggle="dropdown" aria-haspopup="true" aria-expanded="false">Compare</a><ul class="dropdown-menu" aria-labelledby="navbarDropdown"><li class='nav-item'><a class="dropdown-item" href="https://www.asktraders.com/broker/forex/" >Forex Brokers</a></li>
<li class='nav-item'><a class="dropdown-item" href="https://www.asktraders.com/broker/cfd/" >CFD Brokers</a></li>
<li class='nav-item'><a class="dropdown-item" href="https://www.asktraders.com/broker/stocks/" >Stock Brokers</a></li>
<li class='nav-item'><a class="dropdown-item" href="https://www.asktraders.com/broker/crypto-broker/" >Crypto Brokers</a></li>
<li class='nav-item'><a class="dropdown-item" href="https://www.asktraders.com/broker/social-trading/" >Social Trading Brokers</a></li>
<li class='nav-item'><a class="dropdown-item" href="https://www.asktraders.com/broker/robo-advisor/" >Robo Advisors</a></li>
<li class='nav-item'><a class="dropdown-item" href="https://www.asktraders.com/broker-reviews/" >Broker Reviews</a></li>
<li class='nav-item'><a class="dropdown-item" href="https://www.asktraders.com/broker/best-brokers/" >Best Brokers</a></li>
<li class='nav-item'><a class="dropdown-item" href="https://www.asktraders.com/broker/spread-betting/" >Spread Betting Brokers</a></li>
</ul>
</li>
<li class='nav-item dropdown'><a class="nav-link dropdown-toggle"  href="#" role="button" data-toggle="dropdown" aria-haspopup="true" aria-expanded="false">Learn</a><ul class="dropdown-menu" aria-labelledby="navbarDropdown"><li class='nav-item'><a class="dropdown-item" href="https://www.asktraders.com/learn-to-trade/forex-trading/" >Forex Trading</a></li>
<li class='nav-item'><a class="dropdown-item" href="https://www.asktraders.com/learn-to-trade/cfd-trading/" >CFD Trading</a></li>
<li class='nav-item'><a class="dropdown-item" href="https://www.asktraders.com/learn-to-trade/stock-trading/" >Stock Trading</a></li>
<li class='nav-item'><a class="dropdown-item" href="https://www.asktraders.com/learn-to-trade/crypto-trading/" >Crypto Trading</a></li>
<li class='nav-item'><a class="dropdown-item" href="https://www.asktraders.com/learn-to-trade/trading-strategies/" >Trading Strategies</a></li>
<li class='nav-item'><a class="dropdown-item" href="https://www.asktraders.com/learn-to-trade/trading-terminology/" >Trading Terminology</a></li>
<li class='nav-item'><a class="dropdown-item" href="https://www.asktraders.com/learn-to-trade/technical-analysis/" >Technical Analysis</a></li>
<li class='nav-item'><a class="dropdown-item" href="https://www.asktraders.com/learn-to-trade/trading-guide/" >Trading Guides</a></li>
<li class='nav-item'><a class="dropdown-item" href="https://www.asktraders.com/learn-to-trade/guides/" >Broker Guides</a></li>
<li class='nav-item'><a class="dropdown-item" href="https://www.asktraders.com/learn-to-trade/ethical-trading/" >Ethical Trading</a></li>
<li class='nav-item'><a class="dropdown-item" href="https://www.asktraders.com/learn-to-trade/risk-management/" >Risk Management</a></li>
</ul>
</li>
<li class='nav-item dropdown'><a class="nav-link dropdown-toggle"  href="#" role="button" data-toggle="dropdown" aria-haspopup="true" aria-expanded="false">Discuss</a><ul class="dropdown-menu" aria-labelledby="navbarDropdown"><li class='nav-item'><a class="dropdown-item" href="https://www.asktraders.com/trading-community/" >Questions & Answers</a></li>
<li class='nav-item'><a class="dropdown-item" href="https://www.asktraders.com/trading-community/forum/37-broker-complaints/" >Broker Complaints</a></li>
<li class='nav-item'><a class="dropdown-item" href="https://www.asktraders.com/trading-blog/" >Trading Blog</a></li>
</ul>
</li>
<li class='nav-item dropdown'><a class="nav-link dropdown-toggle"  href="#" role="button" data-toggle="dropdown" aria-haspopup="true" aria-expanded="false">Trade</a><ul class="dropdown-menu" aria-labelledby="navbarDropdown"><li class='nav-item'><a class="dropdown-item" href="/trading-ideas/" >Trade Ideas</a></li>
<li class='nav-item'><a class="dropdown-item" href="https://www.asktraders.com/analysis/" >Market Analysis</a></li>
</ul>
</li>
<li class='nav-item'><a class="nav-link" href="https://www.asktraders.com/our-contributors/" >Our Team</a></li>
</ul>
				<button type="button" class="close nav-close" aria-label="Close" data-dismiss="modal">
    <span aria-hidden="true">
						<svg xmlns="http://www.w3.org/2000/svg" width="24" height="24" viewBox="0 0 24 24" fill="none" stroke="currentColor" stroke-width="2" stroke-linecap="round" stroke-linejoin="round" class="feather feather-x"><line x1="18" y1="6" x2="6" y2="18"></line><line x1="6" y1="6" x2="18" y2="18"></line></svg>
					  </span>
</button>
			</div>

			<button class="navbar-toggler ml-2 collapsed" type="button" data-toggle="modal" data-target="#navbarSupportedContent" aria-controls="navbarSupportedContent" aria-expanded="false" aria-label="Toggle navigation">
    <svg xmlns="http://www.w3.org/2000/svg" width="24" height="24" viewBox="0 0 24 24" fill="none" stroke="currentColor" stroke-width="2" stroke-linecap="round" stroke-linejoin="round" class="feather feather-menu">
        <line x1="3" y1="12" x2="21" y2="12"></line>
        <line x1="3" y1="6" x2="21" y2="6"></line>
        <line x1="3" y1="18" x2="21" y2="18"></line>
    </svg>
</button>
<button class="btn search-btn" data-toggle="modal" data-target="#search-container-live-search">
    <svg fill="none" whith="24" height="24" viewBox="0 0 24 24" xmlns="http://www.w3.org/2000/svg">
        <path d="m11 19c4.4183 0 8-3.5817 8-8 0-4.4183-3.5817-8-8-8-4.4183 0-8 3.5817-8 8 0 4.4183 3.5817 8 8 8z" stroke="#555" stroke-linecap="round" stroke-linejoin="round" stroke-width="2" />
        <path d="m21 21-4.35-4.35" stroke="#555" stroke-linecap="round" stroke-linejoin="round" stroke-width="2" />
    </svg>
</button>
<div class="search-container-live-search" id="search-container-live-search">
    <form method="post" class="search-form-element">
        <input type="text" placeholder="Type for search" class="search-content" value="" />
        <button type="submit" class="search-submit">
        	<svg fill="none" whith="24" height="24" viewBox="0 0 24 24" xmlns="http://www.w3.org/2000/svg">
        		<path d="m11 19c4.4183 0 8-3.5817 8-8 0-4.4183-3.5817-8-8-8-4.4183 0-8 3.5817-8 8 0 4.4183 3.5817 8 8 8z" stroke="#555" stroke-linecap="round" stroke-linejoin="round" stroke-width="2"></path>
        		<path d="m21 21-4.35-4.35" stroke="#555" stroke-linecap="round" stroke-linejoin="round" stroke-width="2"></path>
    		</svg>
    	</button>
    </form>
</div>

		</nav>

	</header>

<!-- Breadcrumbs -->
<nav class="breadcrumb" aria-label="breadcrumb"><span><span><a href="https://www.asktraders.com/"><span class="breadcrumb-home">Home</span><i class="ask-icon ask-home-icon"></i></a> <span class="separator"></span> <span><a href="https://www.asktraders.com/Market%20Analysis/">analysis</a> <span class="separator"></span> <span class="breadcrumb_last" aria-current="page">Snap Stock Price Slumps 22%, Blaming Apple’s Tweaks for Revenue Drop</span></span></span></span></nav><!-- EOF Breadcrumbs -->

<div class="container-fluid at-detail-centre ">


	
<!-- Header Banner -->
					 <div class='container-fluid' >
						<a
			href="https://www.asktraders.com/en/go/native?placement=AT-UK-EN-main-NCTA-B1-NA-NA-NA"
			class="at-out"
			data-out="bcta"
			data-position="1"
			data-name="native"
			data-product="unset"
					rel="sponsored noopener" target="_blank"
		>
			<!-- IMG -->
			<img
			class="at-banner-ad d-none d-md-block"
			data-skip-lazy=""
			width="970"
			height="250"
			src="https://www.asktraders.com/wp-content/uploads/2021/03/ATNewsbanner.png"
			alt="new-recommended-broker-banner" />
			<!-- EOF IMG -->
		</a>

					<a
			href="https://www.asktraders.com/en/go/native?placement=AT-UK-EN-main-NCTA-B1-NA-NA-NA"
			class="at-out"
			data-out="bcta"
			data-position="1"
			data-name="native"
			data-product="unset"
							rel="sponsored noopener" target="_blank"
			>

				<!-- Mobile Img -->
				<img
					class="at-banner-ad d-block d-md-none"
					data-skip-lazy=""
					width="300"
					height="250"
					src="https://www.asktraders.com/wp-content/uploads/2021/03/ATNewsbannermobile.png"
					alt="new-recommended-broker-banner" />
				<!-- EOF Mobile Img -->
			</a>
		
					</div>
	<!-- EOF Header Banner -->


	<!-- BUTTON WRAPPER -->

		<div id="at-button-wrapper" class="at-button-wrapper">
									<div class="at-button-group sticky2">
				<div clas="container">
					<a class="btn btn-secondary at-out" href="https://www.asktraders.com/uk/go/etoro?placement=AT-UK-EN-not_defined-NW-B1-NA-NA-NA" data-out="cta" data-name="etoro" data-product="unset" data-lang="uk" target="_blank" rel="sponsored noopener">
					Trade Snap Stock					</a>
										<small class="text-center riskhint text-muted d-block">Your Capital Is At Risk</small>
									</div>
			</div>
			
			<div class="container at-title-bar">
				
<div class="at-title-center">
	<!-- NEWS LIVE REPORTING FEATURE -->
		<!-- EOF LIVE REPORTING FEATURE -->

	<h1>Snap Stock Price Slumps 22%, Blaming Apple’s Tweaks for Revenue Drop</h1>
		<!-- Related Broker -->
		
		<!-- EOF Related Broker -->
		<div class="at-time-social">
			<div class="at-time-stamp">
				<svg fill="none" viewBox="0 0 24 24" xmlns="http://www.w3.org/2000/svg"><path d="m12 22c5.5228 0 10-4.4772 10-10 0-5.5228-4.4772-10-10-10-5.5228 0-10 4.4772-10 10 0 5.5228 4.4772 10 10 10z" stroke="#555" stroke-linecap="round" stroke-linejoin="round" stroke-width="2"/><path d="m12 6v6l4 2" stroke="#555" stroke-linecap="round" stroke-linejoin="round" stroke-width="2"/></svg>
					Updated: 22 Oct 2021			</div>

			<div class="at-social-title">
										<a href="http://twitter.com/share?url=https://www.asktraders.com/analysis/snap-stock-price-slumps-22-blaming-apples-tweaks-for-revenue-drop" class="at-social-icon" rel="nofollow noopener" target="_blank"><svg width="30" height="30" viewBox="0 0 30 30" fill="none" xmlns="http://www.w3.org/2000/svg"> <ellipse cx="15" cy="14.5" rx="13" ry="13.5" fill="#30464F"/> <path fill-rule="evenodd" clip-rule="evenodd" d="M15 0C6.71573 0 0 6.71573 0 15C0 23.2843 6.71573 30 15 30C23.2843 30 30 23.2843 30 15C30 6.71573 23.2843 0 15 0ZM14.5822 12.7112L14.5508 12.1922C14.4563 10.8469 15.2852 9.6182 16.5967 9.14154C17.0794 8.97206 17.8978 8.95087 18.4329 9.09917C18.6427 9.16273 19.0414 9.37458 19.3247 9.56524L19.8388 9.91479L20.4054 9.73472C20.7202 9.63939 21.1398 9.4805 21.3287 9.37458C21.5071 9.27924 21.6645 9.22628 21.6645 9.25806C21.6645 9.43813 21.2762 10.0525 20.951 10.3915C20.5103 10.8681 20.6362 10.9105 21.5281 10.5927C22.0632 10.4126 22.0737 10.4126 21.9687 10.6139C21.9058 10.7198 21.5805 11.0906 21.2343 11.4295C20.6467 12.0121 20.6152 12.0757 20.6152 12.5629C20.6152 13.315 20.2585 14.8827 19.9018 15.7407C19.2408 17.3507 17.8243 19.0138 16.4079 19.8506C14.4144 21.0264 11.7598 21.3229 9.52499 20.6344C8.78005 20.4014 7.5 19.8082 7.5 19.7023C7.5 19.6705 7.88821 19.6281 8.36036 19.6175C9.34663 19.5964 10.3329 19.321 11.1723 18.8337L11.7388 18.4947L11.0883 18.2723C10.165 17.9545 9.33613 17.2236 9.12629 16.5351C9.06334 16.3127 9.08432 16.3021 9.67188 16.3021L10.2804 16.2915L9.76631 16.0479C9.15777 15.7407 8.60168 15.2217 8.32888 14.692C8.12953 14.3107 7.87772 13.3468 7.95116 13.2726C7.97215 13.2408 8.19248 13.3044 8.4443 13.3891C9.16826 13.654 9.26269 13.5904 8.843 13.1455C8.05609 12.3405 7.81477 11.1435 8.19248 10.0101L8.37085 9.50169L9.06334 10.1902C10.4798 11.5778 12.148 12.404 14.0576 12.6477L14.5822 12.7112Z" fill="#F2F2F2"/> </svg></a>
					<a href="http://www.linkedin.com/shareArticle?mini=true&url=https://www.asktraders.com/analysis/snap-stock-price-slumps-22-blaming-apples-tweaks-for-revenue-drop" class="at-social-icon" rel="nofollow noopener" target="_blank"><svg width="30" height="30" viewBox="0 0 30 30" fill="none" xmlns="http://www.w3.org/2000/svg"> <ellipse cx="15" cy="14.5" rx="13" ry="13.5" fill="#30464F"/> <path fill-rule="evenodd" clip-rule="evenodd" d="M15 0C6.71573 0 0 6.71573 0 15C0 23.2843 6.71573 30 15 30C23.2843 30 30 23.2843 30 15C30 6.71573 23.2843 0 15 0ZM16.5636 15.6589V23.8197H13.187V15.6592H11.5001V12.8469H13.187V11.1585C13.187 8.86425 14.1396 7.5 16.8459 7.5H19.0989V10.3126H17.6906C16.6371 10.3126 16.5674 10.7056 16.5674 11.4391L16.5636 12.8466H19.1149L18.8163 15.6589H16.5636Z" fill="#F2F2F2"/> <rect x="6.75" y="5.83325" width="17.4167" height="17.4167" fill="#30464F"/> <path d="M21.4167 4H8.58333C6.05242 4 4 6.05242 4 8.58333V21.4167C4 23.9476 6.05242 26 8.58333 26H21.4167C23.9485 26 26 23.9476 26 21.4167V8.58333C26 6.05242 23.9485 4 21.4167 4ZM11.3333 21.4167H8.58333V11.3333H11.3333V21.4167ZM9.95833 10.171C9.07283 10.171 8.35417 9.44683 8.35417 8.554C8.35417 7.66117 9.07283 6.937 9.95833 6.937C10.8438 6.937 11.5625 7.66117 11.5625 8.554C11.5625 9.44683 10.8448 10.171 9.95833 10.171ZM22.3333 21.4167H19.5833V16.2797C19.5833 13.1923 15.9167 13.4261 15.9167 16.2797V21.4167H13.1667V11.3333H15.9167V12.9513C17.1963 10.5808 22.3333 10.4057 22.3333 15.2209V21.4167Z" fill="#F2F2F2"/> </svg></a>
					<a href="https://www.facebook.com/sharer/sharer.php?u=https://www.asktraders.com/analysis/snap-stock-price-slumps-22-blaming-apples-tweaks-for-revenue-drop" class="at-social-icon" rel="nofollow noopener" target="_blank"><svg width="30" height="30" viewBox="0 0 30 30" fill="none" xmlns="http://www.w3.org/2000/svg"> <ellipse cx="15" cy="14.5" rx="13" ry="13.5" fill="#30464F"/> <path fill-rule="evenodd" clip-rule="evenodd" d="M15 0C6.71573 0 0 6.71573 0 15C0 23.2843 6.71573 30 15 30C23.2843 30 30 23.2843 30 15C30 6.71573 23.2843 0 15 0ZM16.5636 15.6589V23.8197H13.187V15.6592H11.5001V12.8469H13.187V11.1585C13.187 8.86425 14.1396 7.5 16.8459 7.5H19.0989V10.3126H17.6906C16.6371 10.3126 16.5674 10.7056 16.5674 11.4391L16.5636 12.8466H19.1149L18.8163 15.6589H16.5636Z" fill="#F2F2F2"/> </svg></a>
			</div>
		</div>

</div>
			</div>
			<div id="sidebar1" class="sidebar1">
					
			<a  class="row at-author at-side" href="https://www.asktraders.com/our-contributors/nigel-frith/">
									<img width="60" height="60" src="https://www.asktraders.com/wp-content/uploads/2019/04/Nigel_Frith_BW-1-64x64.jpg" class="rounded-circle, skip-lazy wp-post-image" alt="Nigel Firth" srcset="https://www.asktraders.com/wp-content/uploads/2019/04/Nigel_Frith_BW-1-64x64.jpg 64w, https://www.asktraders.com/wp-content/uploads/2019/04/Nigel_Frith_BW-1-150x150.jpg 150w, https://www.asktraders.com/wp-content/uploads/2019/04/Nigel_Frith_BW-1-100x100.jpg 100w, https://www.asktraders.com/wp-content/uploads/2019/04/Nigel_Frith_BW-1-26x26.jpg 26w" sizes="(max-width: 60px) 100vw, 60px" />						<div>
				Nigel Frith			<span>traders</span>
			</div>
			<p>Nigel has been in the regulated financial services industry for nearly a decade, has previously owned a financial brokerage and has written many times for sites relating to personal finance and trading. </p>
		  </a>

												</div>

			
						<!-- Featured Image -->
			<div class="container-featured-image">
								<img width="150" height="150" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20150%20150'%3E%3C/svg%3E" class="attachment-large size-large wp-post-image" alt="SNAP logo" data-lazy-srcset="https://www.asktraders.com/wp-content/uploads/2021/09/SNAP-150x150-1.png 150w, https://www.asktraders.com/wp-content/uploads/2021/09/SNAP-150x150-1-44x44.png 44w" data-lazy-sizes="(max-width: 150px) 100vw, 150px" data-lazy-src="https://www.asktraders.com/wp-content/uploads/2021/09/SNAP-150x150-1.png" /><noscript><img width="150" height="150" src="https://www.asktraders.com/wp-content/uploads/2021/09/SNAP-150x150-1.png" class="attachment-large size-large wp-post-image" alt="SNAP logo" srcset="https://www.asktraders.com/wp-content/uploads/2021/09/SNAP-150x150-1.png 150w, https://www.asktraders.com/wp-content/uploads/2021/09/SNAP-150x150-1-44x44.png 44w" sizes="(max-width: 150px) 100vw, 150px" /></noscript>			</div>
				<!-- TODO:use $acf_fields -->
						<!-- EOF Featured Image -->

			<!-- Lead -->
						<!-- EOF LEAD -->
			
<!-- liveReportDisabled -->
	<div class="container">
		<p><span style="font-weight: 400;">The stock price of camera and social-media company Snap Inc (NYSE: SNAP) is approaching losses of nearly 50% in the last two days. It seems that the recent Q3 report illuminated some problems with marketing; placing the blame on the shoulders of Apple’s recent tweaks. </span></p>
<p><span style="font-weight: 400;">The Q3 report wasn’t a prominent weight on the stock price of Snap; with analysts suggesting the Q3 dip is a hallmark of a much wider change to the mobile advertising space. Arguably, investors could have seen this coming as soon as Apple went ahead with the policy changes &#8211; with various platforms warning for months in advance that advertising revenue may not be what it once was. </span></p>
<p><span style="font-weight: 400;">With Apple users now having to grant permission for the process that allows ad-targeting, companies that utilize mobile advertising to meet revenue targets are left lagging behind analyst expectations. Yet with Snap Inc only missing its guidance by $3 million &#8211; the stock tank bears witness to wider angst in the advertising space.</span></p><div class='code-block code-block-4 ai-viewport-2 ai-viewport-3' style='margin: 8px 0; clear: both;'>
<a href="https://asktraders.com/en/go/native?placement=AT-UK-EN-stocks-NA-MN-NA-NA-NA"><img class="at-banner-ad d-none d-md-block" data-skip-lazy="" width="970" height="250" src="https://www.asktraders.com/wp-content/uploads/2021/03/ATNewsbanner.png" alt="new-recommended-broker-banner"></a></div>

<p><span style="font-weight: 400;">As the marketing wave battles with user privacy, the future landscape of mobile advertising may be laden with problems; especially for those who rely on ad-targeting for maximizing revenue potential. It will be interesting to see how this will affect other social applications and whether it will spur any change before we see Q4 results. </span></p>
<p><span style="font-weight: 400;">SNAP stock is continuing to plummet moving into mid-market Friday, with a total daily loss of just under 25% &#8211; approaching a total 50% sell-off in the last two days of trading. </span></p>
<p>&nbsp;</p>
<!-- AI CONTENT END 1 -->
	</div>


			<div class="container">
			 <!-- FAQ -->
									<!-- EOF FAQ -->
			</div>
				<!-- TODO:backend field / jumplink / banner -->
			 <!-- RISK BOX -->
		 					<div class="container">
						<p class="broker-warning">CFDs are complex instruments and come with a high risk of losing money rapidly due to leverage . 75 % of retail investor accounts lose money when trading CFDs with this provider . You should consider whether you understand how CFDs work, and whether you can afford to take the high risk of losing your money . </p>
					</div>
							<!-- EOF RISK BOX -->

				<!-- GUIDES -->
									<!-- EOF GUIDES -->


			<!-- Related content -->
								<div class="container">
					<h3 class="h2">
						People Who Read This Also Read:					</h3>
					<ul>
												<li>
							<a href="https://www.asktraders.com/analysis/phunware-stock-price-rallied-314-premarket/" title="Phunware Stock Price Rallied 314.4% Premarket on Trump Social Media Links"
														>
								Phunware Stock Price Rallied 314.4% Premarket on Trump Social Media Links		</a>
		</li>
								<li>
							<a href="https://www.asktraders.com/learn-to-trade/stock-trading/best-tech-stocks-to-buy/" title="Best Tech Stocks to Buy Right Now"
														>
								Best Tech Stocks to Buy Right Now		</a>
		</li>
				</ul>
		</div>
				<!-- EOF Related content -->

		</div>
		<!-- EOF BUTTON WRAPPER -->


		
		</div>


		

<footer class="at-page-footer border-top">
<div class="container">
	<div class="row">
	<h2>Before you trade, AskTraders.</h2>

													<a href="https://www.asktraders.com/en/go/native?placement=AT-UK-EN-default-NCTA-B1-NA-NA-NA" class="btn btn-secondary"
									target="_blank"				>Start Trading</a>
					
	
	</div>
	<div class="row">
	<div class="col-4">
		<div class="risk-warning-container">
		<svg width="24" height="24" viewBox="0 0 24 24" fill="none" xmlns="http://www.w3.org/2000/svg">
		<path d="M10.29 3.85996L1.82002 18C1.64539 18.3024 1.55299 18.6453 1.55201 18.9945C1.55103 19.3437 1.64151 19.6871 1.81445 19.9905C1.98738 20.2939 2.23675 20.5467 2.53773 20.7238C2.83871 20.9009 3.18082 20.9961 3.53002 21H20.47C20.8192 20.9961 21.1613 20.9009 21.4623 20.7238C21.7633 20.5467 22.0127 20.2939 22.1856 19.9905C22.3585 19.6871 22.449 19.3437 22.448 18.9945C22.4471 18.6453 22.3547 18.3024 22.18 18L13.71 3.85996C13.5318 3.56607 13.2807 3.32308 12.9812 3.15444C12.6817 2.98581 12.3438 2.89722 12 2.89722C11.6563 2.89722 11.3184 2.98581 11.0188 3.15444C10.7193 3.32308 10.4683 3.56607 10.29 3.85996V3.85996Z" stroke="#FF8C00" stroke-width="2" stroke-linecap="round" stroke-linejoin="round" />
		<path d="M12 9V13" stroke="#FF8C00" stroke-width="2" stroke-linecap="round" stroke-linejoin="round" />
		<path d="M12 17H12.01" stroke="#FF8C00" stroke-width="2" stroke-linecap="round" stroke-linejoin="round" /></svg>

		<h6>Risk warning</h6>
		<small>Trading financial products carries a high risk to your capital, especially trading leverage products such as CFDs. They may not be suitable for everyone. Please make sure that you fully understand the risks. You should consider whether you can afford to take the risk of losing your money.</small>
		<h6>Advertiser Disclosure</h6>
		<small>Asktraders is a free website that is supported by our advertising partners. As such we may earn a commision when you make a purchase after following a link from our website.		</small>

		</div>
	</div>
	<!-- Special part for landinpage templates from WSAM landinpage2 Plugin -->

<div class="col-2"><h6>Compare</h6><div class="menu-footer-1-container"><ul id="menu-footer-1" class="menu"><li id="menu-item-65926" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-65926"><a href="https://www.asktraders.com/broker/forex/">Forex Brokers</a></li>
<li id="menu-item-65927" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-65927"><a href="https://www.asktraders.com/broker/cfd/">CFD Brokers</a></li>
<li id="menu-item-65922" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-65922"><a href="https://www.asktraders.com/broker/stocks/">Stock Brokers</a></li>
<li id="menu-item-65928" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-65928"><a href="https://www.asktraders.com/broker/crypto-broker/">Crypto Brokers</a></li>
<li id="menu-item-70360" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-70360"><a href="https://www.asktraders.com/broker/crypto-exchange/">Crypto Exchanges</a></li>
<li id="menu-item-65929" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-65929"><a href="https://www.asktraders.com/broker/etf/">ETF Brokers</a></li>
<li id="menu-item-70635" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-70635"><a href="https://www.asktraders.com/high-leverage-broker-comparison/">High Leverage Brokers</a></li>
<li id="menu-item-65924" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-65924"><a href="https://www.asktraders.com/broker/social-trading/">Social Trading Brokers</a></li>
<li id="menu-item-72858" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-72858"><a href="https://www.asktraders.com/broker/sports-trading/">Sports Trading Brokers</a></li>
<li id="menu-item-65923" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-65923"><a href="https://www.asktraders.com/broker/spread-betting/">Spread Betting Brokers</a></li>
<li id="menu-item-65925" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-65925"><a href="https://www.asktraders.com/broker/robo-advisor/">Robo Advisors</a></li>
<li id="menu-item-91980" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-91980"><a href="https://www.asktraders.com/broker/best-brokers/">Best Brokers</a></li>
<li id="menu-item-91982" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-91982"><a href="https://www.asktraders.com/broker-reviews/">Broker Reviews</a></li>
</ul></div></div><div class="col-2"><h6>Learn</h6><div class="menu-footer-2-container"><ul id="menu-footer-2" class="menu"><li id="menu-item-65933" class="menu-item menu-item-type-taxonomy menu-item-object-tradingcategory menu-item-65933"><a href="https://www.asktraders.com/learn-to-trade/forex-trading/">Forex Trading</a></li>
<li id="menu-item-65931" class="menu-item menu-item-type-taxonomy menu-item-object-tradingcategory menu-item-65931"><a href="https://www.asktraders.com/learn-to-trade/cfd-trading/">CFD Trading</a></li>
<li id="menu-item-65935" class="menu-item menu-item-type-taxonomy menu-item-object-tradingcategory menu-item-65935"><a href="https://www.asktraders.com/learn-to-trade/stock-trading/">Stocks Trading</a></li>
<li id="menu-item-65932" class="menu-item menu-item-type-taxonomy menu-item-object-tradingcategory menu-item-65932"><a href="https://www.asktraders.com/learn-to-trade/crypto-trading/">Crypto Trading</a></li>
<li id="menu-item-65936" class="menu-item menu-item-type-taxonomy menu-item-object-tradingcategory menu-item-65936"><a href="https://www.asktraders.com/learn-to-trade/technical-analysis/">Technical Analysis</a></li>
<li id="menu-item-65937" class="menu-item menu-item-type-taxonomy menu-item-object-tradingcategory menu-item-65937"><a href="https://www.asktraders.com/learn-to-trade/trading-guide/">Trading Guides</a></li>
<li id="menu-item-65930" class="menu-item menu-item-type-taxonomy menu-item-object-tradingcategory menu-item-65930"><a href="https://www.asktraders.com/learn-to-trade/guides/">Broker Guides</a></li>
<li id="menu-item-65934" class="menu-item menu-item-type-taxonomy menu-item-object-tradingcategory menu-item-65934"><a href="https://www.asktraders.com/learn-to-trade/risk-management/">Risk Management</a></li>
<li id="menu-item-80167" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-80167"><a href="https://www.asktraders.com/learn-to-trade/sports-betting-trading/">Sports Trading</a></li>
<li id="menu-item-69923" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-69923"><a href="https://www.asktraders.com/learn-to-trade/ethical-trading/">Ethical Trading</a></li>
</ul></div></div><div class="col-2"><h6>Discuss</h6><div class="menu-footer-3-container"><ul id="menu-footer-3" class="menu"><li id="menu-item-65939" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-65939"><a href="https://www.asktraders.com/trading-community/">Questions &#038; Answers</a></li>
<li id="menu-item-101514" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-101514"><a href="https://www.asktraders.com/trading-community/forum/37-broker-complaints/">Broker Complaints</a></li>
</ul></div></div><div class="col-2"><h6>Trade</h6><div class="menu-footer-4-container"><ul id="menu-footer-4" class="menu"><li id="menu-item-65942" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-65942"><a href="/analysis/">Market Analysis</a></li>
<li id="menu-item-99186" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-99186"><a href="https://www.asktraders.com/broker-reviews/ig/">IG Review</a></li>
<li id="menu-item-99187" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-99187"><a href="https://www.asktraders.com/broker-reviews/admiral-markets/">Admiral Markets Review</a></li>
<li id="menu-item-99188" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-99188"><a href="https://www.asktraders.com/broker-reviews/pepperstone/">Pepperstone Review</a></li>
</ul></div></div>


	</div>
	<div class="footer-social">
	<a href="https://www.facebook.com/asktraderscom/" target="_blank" rel="noopener noreferrer">
		<svg viewBox="0 0 40 40" fill="none" xmlns="http://www.w3.org/2000/svg">
		<circle cx="19.5" cy="19.5" r="15.5" fill="#30464F" />
		<path fill-rule="evenodd" clip-rule="evenodd" d="M20 0C8.95431 0 0 8.95431 0 20C0 31.0457 8.95431 40 20 40C31.0457 40 40 31.0457 40 20C40 8.95431 31.0457 0 20 0ZM22.0847 20.8785V31.7596H17.5826V20.8789H15.3334V17.1293H17.5826V14.878C17.5826 11.819 18.8527 10 22.461 10H25.4651V13.7501H23.5873C22.1827 13.7501 22.0898 14.2741 22.0898 15.2521L22.0847 17.1288H25.4864L25.0883 20.8785H22.0847Z" fill="#F2F2F2" /></svg></a>
	  <a href="https://www.instagram.com/asktraderscom/" target="_blank" rel="noopener noreferrer">
		<svg viewBox="0 0 40 40" xmlns="http://www.w3.org/2000/svg">
		<circle cx="20.5" cy="20.5" r="16.5" fill="#30464F" />
		<path d="m20 0c-11.046 0-20 8.9543-20 20 0 11.046 8.9543 20 20 20 11.046 0 20-8.9543 20-20 0-11.046-8.9543-20-20-20zm-4.3972 9.3984c1.1378-0.05178 1.5013-0.06445 4.3982-0.06445h-0.0033c2.8978 0 3.26 0.01267 4.3978 0.06445 1.1356 0.052 1.9112 0.23178 2.5912 0.49556 0.7022 0.27221 1.2955 0.63671 1.8889 1.23 0.5933 0.5929 0.9578 1.188 1.2311 1.8896 0.2622 0.6782 0.4422 1.4533 0.4956 2.5889 0.0511 1.1378 0.0644 1.5013 0.0644 4.3983 0 2.8969-0.0133 3.2596-0.0644 4.3973-0.0534 1.1352-0.2334 1.9105-0.4956 2.589-0.2733 0.7013-0.6378 1.2964-1.2311 1.8893-0.5927 0.5933-1.1869 0.9587-1.8883 1.2311-0.6786 0.2638-1.4546 0.4436-2.5902 0.4956-1.1378 0.0518-1.5003 0.0644-4.3974 0.0644-2.8967 0-3.26-0.0126-4.3978-0.0644-1.1354-0.052-1.9107-0.2318-2.5894-0.4956-0.7011-0.2724-1.2962-0.6378-1.8889-1.2311-0.5931-0.5929-0.9576-1.188-1.2302-1.8896-0.26356-0.6782-0.44334-1.4533-0.49556-2.5889-0.05156-1.1378-0.06445-1.5002-0.06445-4.3971 0-2.897 0.01334-3.2607 0.06423-4.3985 0.05111-1.1352 0.23111-1.9105 0.49556-2.5889 0.27334-0.7014 0.63774-1.2965 1.2311-1.8894 0.5929-0.5931 1.188-0.9576 1.8896-1.23 0.6782-0.26378 1.4533-0.44356 2.5889-0.49556z" clip-rule="evenodd" fill="#F2F2F2" fill-rule="evenodd" />
		<path d="m19.044 11.256c0.1858-3e-4 0.3857-2e-4 0.6014-1e-4l0.3555 1e-4c2.848 0 3.1856 0.0102 4.3103 0.0613 1.04 0.0476 1.6044 0.2214 1.9804 0.3674 0.4978 0.1933 0.8527 0.4244 1.2258 0.7978 0.3734 0.3733 0.6045 0.7289 0.7983 1.2266 0.146 0.3756 0.32 0.94 0.3673 1.9801 0.0511 1.1244 0.0622 1.4622 0.0622 4.3089s-0.0111 3.1845-0.0622 4.3089c-0.0476 1.04-0.2213 1.6045-0.3673 1.98-0.1934 0.4978-0.4249 0.8523-0.7983 1.2254-0.3733 0.3733-0.7278 0.6044-1.2258 0.7978-0.3755 0.1466-0.9404 0.32-1.9804 0.3675-1.1245 0.0511-1.4623 0.0623-4.3103 0.0623-2.8482 0-3.1858-0.0112-4.3103-0.0623-1.04-0.048-1.6044-0.2217-1.9806-0.3677-0.4978-0.1934-0.8534-0.4245-1.2267-0.7978-0.3734-0.3734-0.6045-0.728-0.7983-1.226-0.146-0.3756-0.32-0.9401-0.3673-1.9801-0.0511-1.1244-0.0613-1.4622-0.0613-4.3107s0.0102-3.1845 0.0613-4.3089c0.0476-1.04 0.2213-1.6045 0.3673-1.9805 0.1934-0.4978 0.4249-0.8533 0.7983-1.2267 0.3733-0.3733 0.7289-0.6044 1.2267-0.7982 0.376-0.1467 0.9406-0.32 1.9806-0.3678 0.984-0.0444 1.3654-0.0577 3.3534-0.06v0.0027zm6.6507 1.7712c-0.7067 0-1.28 0.5727-1.28 1.2796 0 0.7067 0.5733 1.28 1.28 1.28s1.28-0.5733 1.28-1.28-0.5733-1.28-1.28-1.28v4e-4zm-11.172 6.9735c0-3.0251 2.4526-5.4777 5.4776-5.4778 3.0251 0 5.4772 2.4527 5.4772 5.4778s-2.4518 5.4767-5.477 5.4767c-3.0251 0-5.4778-2.4516-5.4778-5.4767z" clip-rule="evenodd" fill="#F2F2F2" fill-rule="evenodd" />
		<path d="m20.001 16.444c1.9636 0 3.5556 1.5918 3.5556 3.5556 0 1.9636-1.592 3.5556-3.5556 3.5556-1.9638 0-3.5556-1.592-3.5556-3.5556 0-1.9638 1.5918-3.5556 3.5556-3.5556z" clip-rule="evenodd" fill="#F2F2F2" fill-rule="evenodd" /></svg></a>
	  <a href="https://twitter.com/Asktraders1" target="_blank" rel="noopener noreferrer">
		<svg viewBox="0 0 40 40" fill="none" xmlns="http://www.w3.org/2000/svg">
		<circle cx="19.5" cy="19.5" r="15.5" fill="#30464F" />
		<path fill-rule="evenodd" clip-rule="evenodd" d="M20 0C8.95431 0 0 8.95431 0 20C0 31.0457 8.95431 40 20 40C31.0457 40 40 31.0457 40 20C40 8.95431 31.0457 0 20 0ZM19.443 16.9483L19.401 16.2563C19.2751 14.4626 20.3803 12.8243 22.129 12.1887C22.7725 11.9627 23.8637 11.9345 24.5772 12.1322C24.8569 12.217 25.3885 12.4994 25.7663 12.7537L26.4518 13.2197L27.2072 12.9796C27.6269 12.8525 28.1865 12.6407 28.4383 12.4994C28.6761 12.3723 28.8859 12.3017 28.8859 12.3441C28.8859 12.5842 28.3683 13.4033 27.9347 13.8553C27.3471 14.4908 27.515 14.5473 28.7041 14.1236C29.4175 13.8835 29.4315 13.8835 29.2916 14.1519C29.2077 14.2931 28.774 14.7874 28.3124 15.2394C27.529 16.0162 27.487 16.1009 27.487 16.7506C27.487 17.7533 27.0113 19.8436 26.5357 20.9876C25.6543 23.1343 23.7658 25.3517 21.8772 26.4674C19.2191 28.0351 15.6798 28.4306 12.7 27.5126C11.7067 27.2019 10 26.411 10 26.2697C10 26.2274 10.5176 26.1709 11.1471 26.1567C12.4622 26.1285 13.7772 25.7613 14.8964 25.1116L15.6518 24.6597L14.7844 24.3631C13.5534 23.9394 12.4482 22.9649 12.1684 22.0468C12.0844 21.7502 12.1124 21.7361 12.8958 21.7361L13.7072 21.722L13.0218 21.3972C12.2104 20.9876 11.4689 20.2955 11.1052 19.5894C10.8394 19.0809 10.5036 17.7957 10.6016 17.6968C10.6295 17.6545 10.9233 17.7392 11.2591 17.8522C12.2243 18.2053 12.3503 18.1205 11.7907 17.5274C10.7414 16.454 10.4197 14.858 10.9233 13.3468L11.1611 12.6689L12.0844 13.5869C13.973 15.4371 16.1974 16.5387 18.7435 16.8636L19.443 16.9483Z" fill="#F2F2F2" /></svg></a>
	  <a href="https://www.youtube.com/channel/UCcVX11eWJbZAjVHvvKHIbmg" target="_blank" rel="noopener noreferrer">
		<svg viewBox="0 0 40 40" fill="none" xmlns="http://www.w3.org/2000/svg">
		<circle cx="20.5" cy="20.5" r="16.5" fill="#30464F" />
		<path fill-rule="evenodd" clip-rule="evenodd" d="M20 0C8.95431 0 0 8.95431 0 20C0 31.0457 8.95431 40 20 40C31.0457 40 40 31.0457 40 20C40 8.95431 31.0457 0 20 0ZM28.3346 13.1238C29.2525 13.3757 29.9754 14.1179 30.2208 15.0604C30.6666 16.7685 30.6666 20.3327 30.6666 20.3327C30.6666 20.3327 30.6666 23.8967 30.2208 25.605C29.9754 26.5475 29.2525 27.2897 28.3346 27.5417C26.6711 27.9993 19.9999 27.9993 19.9999 27.9993C19.9999 27.9993 13.3288 27.9993 11.6651 27.5417C10.7472 27.2897 10.0243 26.5475 9.77895 25.605C9.33325 23.8967 9.33325 20.3327 9.33325 20.3327C9.33325 20.3327 9.33325 16.7685 9.77895 15.0604C10.0243 14.1179 10.7472 13.3757 11.6651 13.1238C13.3288 12.666 19.9999 12.666 19.9999 12.666C19.9999 12.666 26.6711 12.666 28.3346 13.1238Z" fill="#F2F2F2" />
		<path fill-rule="evenodd" clip-rule="evenodd" d="M18 24.0007V17.334L23.3333 20.6674L18 24.0007Z" fill="#F2F2F2" /></svg></a>
	  <a class="footer-brand float-right" href="https://www.asktraders.com">
		<svg viewBox="0 0 134 21" xmlns="http://www.w3.org/2000/svg">
		  <g clip-path="url(#d)">
			<path d="m9.7978 20.664-0.77898-3.4193h-4.1509l-0.74805 3.4193h-4.1199l4.868-20.356h4.3055l4.9945 20.356h-4.3702zm-1.4061-6.5635c-0.4359-1.9531-0.87461-3.876-1.1868-5.8593-0.12374-0.88577-0.25029-1.8018-0.3431-2.6848-0.18842 2.8691-0.7818 5.708-1.3724 8.5469l2.9022-0.0027z" />
			<path d="m23.527 4.9159c-0.8437-0.70147-1.8111-1.3122-2.9641-1.3122-1.2177 0-2.0586 0.795-2.0586 1.9834 0 3.5101 6.2432 3.4468 6.2432 9.1246 0 3.5101-2.1542 6.2884-5.931 6.2884-1.2754 0.0139-2.5256-0.3474-3.5884-1.037v-3.8512c0.9364 0.6107 1.9039 1.1003 3.0597 1.1003 1.4061 0 2.4326-0.8555 2.4326-2.2584 0.0053-0.3573-0.0695-0.7113-0.2194-1.0371-0.374-0.762-1.5298-1.4359-2.216-1.8926-2.3398-1.5872-3.8387-3.0534-3.8387-6.0134 0-3.202 1.9039-6.0106 5.4304-6.0106 1.2883-0.017237 2.5554 0.32123 3.6559 0.97655l-0.0056 3.9392z" />
			<path d="m34.363 20.665-3.8387-10.349v10.349h-4.1199v-20.356h4.1199v9.0943l3.4646-9.0971h4.2184l-3.8443 9.4024 4.3055 10.957h-4.3055z" />
			<path d="m46.495 4.0303v16.634h-4.1199v-16.634h-3.2144v-3.7247h10.546v3.7247h-3.2116z" />
			<path d="m58.832 20.664-3.6559-9.3721v9.3721h-4.1143v-20.356h4.463c1.5299 0 3.2144 0.12104 4.5249 0.97656 1.6536 1.0673 2.4663 3.0507 2.4663 4.9515 0 2.319-0.9365 3.9667-2.9641 5.1881l3.6194 9.2484-4.3393-0.0083zm-3.6531-11.587c0.2278 0.02536 0.457 0.03547 0.6862 0.03026 1.7773 0 2.6519-1.1911 2.6519-2.8389s-0.748-2.7784-2.5591-2.7784h-0.7818l0.0028 5.587z" />
			<path d="m73.725 20.664-0.779-3.4193h-4.1508l-0.7396 3.4193h-4.1284l4.868-20.356h4.3055l4.9945 20.356h-4.3702zm-1.4061-6.5635c-0.4359-1.9531-0.8746-3.876-1.1868-5.8593-0.1237-0.88577-0.2502-1.8018-0.343-2.6848-0.1885 2.8691-0.7818 5.708-1.3724 8.5469l2.9022-0.0027z" />
			<path d="m83.264 0.30566c1.5299 0 2.8123 0.060519 4.2184 0.70147 3.7121 1.6505 4.7808 5.9528 4.7808 9.584 0 5.5017-2.1233 10.074-8.4367 10.074h-4.0243v-20.356l3.4618-0.002751zm0.7818 16.634c3.2763 0.0302 4.0862-3.8512 4.0862-6.3793 0-2.0136-0.4668-4.6406-2.1204-5.9831-0.6553-0.55017-1.2486-0.67121-2.0923-0.70147v13.064h0.1265z" />
			<path d="m94.064 20.664v-20.356h8.2675v3.7824h-4.1475v4.4014h3.6555v3.8512h-3.6555v4.5664h4.2185v3.7549h-8.3385z" />
			<path d="m112.29 20.664-3.656-9.3721v9.3721h-4.114v-20.356h4.463c1.529 0 3.214 0.12104 4.524 0.97656 1.654 1.0673 2.467 3.0507 2.467 4.9515 0 2.319-0.937 3.9667-2.964 5.1881l3.616 9.2401h-4.336zm-3.65-11.587c0.227 0.02536 0.457 0.03547 0.686 0.03026 1.777 0 2.652-1.1911 2.652-2.8389s-0.748-2.7784-2.559-2.7784h-0.779v5.587z" />
			<path d="m126.36 4.9159c-0.843-0.70147-1.811-1.3122-2.964-1.3122-1.217 0-2.058 0.795-2.058 1.9834 0 3.5101 6.24 3.4496 6.24 9.1273 0 3.5101-2.154 6.2885-5.931 6.2885-1.275 0.0138-2.525-0.3475-3.588-1.0371v-3.8512c0.936 0.6107 1.904 1.1004 3.059 1.1004 1.406 0 2.433-0.8555 2.433-2.2585 5e-3 -0.3572-0.07-0.7112-0.219-1.0371-0.374-0.7619-1.53-1.4359-2.216-1.8925-2.34-1.5873-3.842-3.0535-3.842-6.0134 0-3.2047 1.91-6.0134 5.433-6.0134 1.289-0.017237 2.556 0.32123 3.656 0.97655l-3e-3 3.9392z" />
			<path d="m129.08 5.4662v-3.9282h-0.843v-0.55017h2.325v0.55017h-0.843v3.9282h-0.639z" />
			<path d="m130.85 5.466 0.393-4.4894h0.563l0.621 3.1085 0.639-3.1085h0.54l0.399 4.4894h-0.563l-0.196-3.147-0.614 3.147h-0.419l-0.599-3.147-0.185 3.147h-0.579z" />
		</g>
		<defs>
			<clipPath>
			<rect width="134" height="21" fill="#fff" />
			</clipPath>
		</defs>
		</svg></a>
	</div>
</div>
<div class="container-fluid">
	<div class="container">
			<ul id="menu-below-footer" class="menu"><li id="menu-item-65987" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-65987"><a href="https://www.asktraders.com/terms-and-conditions/">Terms of Use<span>•</span></a></li>
<li id="menu-item-11736" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-privacy-policy menu-item-11736"><a href="https://www.asktraders.com/privacy-policy/">Privacy &#038; Cookies Policy<span>•</span></a></li>
<li id="menu-item-37038" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-37038"><a target="_blank" rel="noopener noreferrer nofollow" href="https://www.fca.org.uk/">Regulations<span>•</span></a></li>
</ul>		<p class="float-right">© 2021 asktraders</p>
	</div>
</div>
</footer>


	<div class="search-result-main-container popup-search-results hide"></div>				<script type='application/ld+json'>{
    "@context": "https://schema.org",
    "@type": "Person",
    "name": "Nigel Frith",
    "url": "https://www.asktraders.com/our-contributors/nigel-frith/",
    "image": "https://www.asktraders.com/wp-content/uploads/2019/04/Nigel_Frith_BW-1.jpg"
}</script>
<!-- This site is converting visitors into subscribers and customers with OptinMonster - https://optinmonster.com :: Campaign Title: EIP_DE-DE_Admiral Markets --><script>(function(d){var s=d.createElement('script');s.type='text/javascript';s.src='https://a.omappapi.com/app/js/api.min.js';s.async=true;s.dataset.campaign='r9s6sovhqivbdwyvhtyr';s.dataset.user='72840';d.getElementsByTagName('head')[0].appendChild(s);})(document);</script><!-- / OptinMonster --><!-- This site is converting visitors into subscribers and customers with OptinMonster - https://optinmonster.com :: Campaign Title: EIP_EN-GLOBAL_stocks_crypto_forex_open-account-topbroker --><script>(function(d){var s=d.createElement('script');s.type='text/javascript';s.src='https://a.omappapi.com/app/js/api.min.js';s.async=true;s.dataset.campaign='drlldgfozy5ci0n5cbas';s.dataset.user='72840';d.getElementsByTagName('head')[0].appendChild(s);})(document);</script><!-- / OptinMonster -->		<script type="text/javascript">
		var r9s6sovhqivbdwyvhtyr_shortcode = true;var drlldgfozy5ci0n5cbas_shortcode = true;		</script>
		<script type='text/javascript' id='thickbox-js-extra'>
/* <![CDATA[ */
var thickboxL10n = {"next":"Next >","prev":"< Prev","image":"Image","of":"of","close":"Close","noiframes":"This feature requires inline frames. You have iframes disabled or your browser does not support them.","loadingAnimation":"https:\/\/www.asktraders.com\/wp-includes\/js\/thickbox\/loadingAnimation.gif"};
/* ]]> */
</script>
<script data-minify="1" type='text/javascript' src='https://www.asktraders.com/wp-content/cache/min/1/wp-includes/js/thickbox/thickbox.js?ver=1634635969' id='thickbox-js' defer></script>
<script type='text/javascript' id='rocket-browser-checker-js-after'>
"use strict";var _createClass=function(){function defineProperties(target,props){for(var i=0;i<props.length;i++){var descriptor=props[i];descriptor.enumerable=descriptor.enumerable||!1,descriptor.configurable=!0,"value"in descriptor&&(descriptor.writable=!0),Object.defineProperty(target,descriptor.key,descriptor)}}return function(Constructor,protoProps,staticProps){return protoProps&&defineProperties(Constructor.prototype,protoProps),staticProps&&defineProperties(Constructor,staticProps),Constructor}}();function _classCallCheck(instance,Constructor){if(!(instance instanceof Constructor))throw new TypeError("Cannot call a class as a function")}var RocketBrowserCompatibilityChecker=function(){function RocketBrowserCompatibilityChecker(options){_classCallCheck(this,RocketBrowserCompatibilityChecker),this.passiveSupported=!1,this._checkPassiveOption(this),this.options=!!this.passiveSupported&&options}return _createClass(RocketBrowserCompatibilityChecker,[{key:"_checkPassiveOption",value:function(self){try{var options={get passive(){return!(self.passiveSupported=!0)}};window.addEventListener("test",null,options),window.removeEventListener("test",null,options)}catch(err){self.passiveSupported=!1}}},{key:"initRequestIdleCallback",value:function(){!1 in window&&(window.requestIdleCallback=function(cb){var start=Date.now();return setTimeout(function(){cb({didTimeout:!1,timeRemaining:function(){return Math.max(0,50-(Date.now()-start))}})},1)}),!1 in window&&(window.cancelIdleCallback=function(id){return clearTimeout(id)})}},{key:"isDataSaverModeOn",value:function(){return"connection"in navigator&&!0===navigator.connection.saveData}},{key:"supportsLinkPrefetch",value:function(){var elem=document.createElement("link");return elem.relList&&elem.relList.supports&&elem.relList.supports("prefetch")&&window.IntersectionObserver&&"isIntersecting"in IntersectionObserverEntry.prototype}},{key:"isSlowConnection",value:function(){return"connection"in navigator&&"effectiveType"in navigator.connection&&("2g"===navigator.connection.effectiveType||"slow-2g"===navigator.connection.effectiveType)}}]),RocketBrowserCompatibilityChecker}();
</script>
<script type='text/javascript' id='rocket-preload-links-js-extra'>
/* <![CDATA[ */
var RocketPreloadLinksConfig = {"excludeUris":"\/(.+\/)?feed\/?.+\/?|\/(?:.+\/)?embed\/|\/(index\\.php\/)?wp\\-json(\/.*|$)|\/wp-admin\/|\/logout\/|\/log-me-out\/|\/wp-login.php","usesTrailingSlash":"1","imageExt":"jpg|jpeg|gif|png|tiff|bmp|webp|avif","fileExt":"jpg|jpeg|gif|png|tiff|bmp|webp|avif|php|pdf|html|htm","siteUrl":"https:\/\/www.asktraders.com","onHoverDelay":"100","rateThrottle":"3"};
/* ]]> */
</script>
<script type='text/javascript' id='rocket-preload-links-js-after'>
(function() {
"use strict";var r="function"==typeof Symbol&&"symbol"==typeof Symbol.iterator?function(e){return typeof e}:function(e){return e&&"function"==typeof Symbol&&e.constructor===Symbol&&e!==Symbol.prototype?"symbol":typeof e},e=function(){function i(e,t){for(var n=0;n<t.length;n++){var i=t[n];i.enumerable=i.enumerable||!1,i.configurable=!0,"value"in i&&(i.writable=!0),Object.defineProperty(e,i.key,i)}}return function(e,t,n){return t&&i(e.prototype,t),n&&i(e,n),e}}();function i(e,t){if(!(e instanceof t))throw new TypeError("Cannot call a class as a function")}var t=function(){function n(e,t){i(this,n),this.browser=e,this.config=t,this.options=this.browser.options,this.prefetched=new Set,this.eventTime=null,this.threshold=1111,this.numOnHover=0}return e(n,[{key:"init",value:function(){!this.browser.supportsLinkPrefetch()||this.browser.isDataSaverModeOn()||this.browser.isSlowConnection()||(this.regex={excludeUris:RegExp(this.config.excludeUris,"i"),images:RegExp(".("+this.config.imageExt+")$","i"),fileExt:RegExp(".("+this.config.fileExt+")$","i")},this._initListeners(this))}},{key:"_initListeners",value:function(e){-1<this.config.onHoverDelay&&document.addEventListener("mouseover",e.listener.bind(e),e.listenerOptions),document.addEventListener("mousedown",e.listener.bind(e),e.listenerOptions),document.addEventListener("touchstart",e.listener.bind(e),e.listenerOptions)}},{key:"listener",value:function(e){var t=e.target.closest("a"),n=this._prepareUrl(t);if(null!==n)switch(e.type){case"mousedown":case"touchstart":this._addPrefetchLink(n);break;case"mouseover":this._earlyPrefetch(t,n,"mouseout")}}},{key:"_earlyPrefetch",value:function(t,e,n){var i=this,r=setTimeout(function(){if(r=null,0===i.numOnHover)setTimeout(function(){return i.numOnHover=0},1e3);else if(i.numOnHover>i.config.rateThrottle)return;i.numOnHover++,i._addPrefetchLink(e)},this.config.onHoverDelay);t.addEventListener(n,function e(){t.removeEventListener(n,e,{passive:!0}),null!==r&&(clearTimeout(r),r=null)},{passive:!0})}},{key:"_addPrefetchLink",value:function(i){return this.prefetched.add(i.href),new Promise(function(e,t){var n=document.createElement("link");n.rel="prefetch",n.href=i.href,n.onload=e,n.onerror=t,document.head.appendChild(n)}).catch(function(){})}},{key:"_prepareUrl",value:function(e){if(null===e||"object"!==(void 0===e?"undefined":r(e))||!1 in e||-1===["http:","https:"].indexOf(e.protocol))return null;var t=e.href.substring(0,this.config.siteUrl.length),n=this._getPathname(e.href,t),i={original:e.href,protocol:e.protocol,origin:t,pathname:n,href:t+n};return this._isLinkOk(i)?i:null}},{key:"_getPathname",value:function(e,t){var n=t?e.substring(this.config.siteUrl.length):e;return n.startsWith("/")||(n="/"+n),this._shouldAddTrailingSlash(n)?n+"/":n}},{key:"_shouldAddTrailingSlash",value:function(e){return this.config.usesTrailingSlash&&!e.endsWith("/")&&!this.regex.fileExt.test(e)}},{key:"_isLinkOk",value:function(e){return null!==e&&"object"===(void 0===e?"undefined":r(e))&&(!this.prefetched.has(e.href)&&e.origin===this.config.siteUrl&&-1===e.href.indexOf("?")&&-1===e.href.indexOf("#")&&!this.regex.excludeUris.test(e.href)&&!this.regex.images.test(e.href))}}],[{key:"run",value:function(){"undefined"!=typeof RocketPreloadLinksConfig&&new n(new RocketBrowserCompatibilityChecker({capture:!0,passive:!0}),RocketPreloadLinksConfig).init()}}]),n}();t.run();
}());
</script>
<script type='text/javascript' id='plugin-test-frontend-js-js-extra'>
/* <![CDATA[ */
var plugin_frontend_script = {"plugin_frontend_url":"https:\/\/www.asktraders.com\/wp-admin\/admin-ajax.php","plugin_wp_query_vars":{"page":0,"post_type":"news","error":"","m":"","p":129245,"post_parent":"","subpost":"","subpost_id":"","attachment":"","attachment_id":0,"pagename":"","page_id":"","second":"","minute":"","hour":"","day":0,"monthnum":0,"year":0,"w":0,"category_name":"","tag":"","cat":"","tag_id":"","author":"","author_name":"","feed":"","tb":"","paged":0,"meta_key":"","meta_value":"","preview":"","s":"","sentence":"","title":"","fields":"","menu_order":"","embed":"","category__in":[],"category__not_in":[],"category__and":[],"post__in":[],"post__not_in":[],"post_name__in":[],"tag__in":[],"tag__not_in":[],"tag__and":[],"tag_slug__in":[],"tag_slug__and":[],"post_parent__in":[],"post_parent__not_in":[],"author__in":[],"author__not_in":[],"name":"snap-stock-price-slumps-22-blaming-apples-tweaks-for-revenue-drop","ignore_sticky_posts":false,"suppress_filters":false,"cache_results":true,"update_post_term_cache":true,"lazy_load_term_meta":true,"update_post_meta_cache":true,"posts_per_page":23,"nopaging":false,"comments_per_page":"50","no_found_rows":false,"order":"DESC","news":"snap-stock-price-slumps-22-blaming-apples-tweaks-for-revenue-drop"},"plugin_current_search_language":"en"};
/* ]]> */
</script>
<script data-minify="1" type='text/javascript' src='https://www.asktraders.com/wp-content/cache/min/1/wp-content/plugins/wsam-live-search/assets/public/js/frontend.js?ver=1634635969' id='plugin-test-frontend-js-js' defer></script>
<script>(function(d){var s=d.createElement("script");s.type="text/javascript";s.src="https://a.omappapi.com/app/js/api.min.js";s.async=true;s.id="omapi-script";d.getElementsByTagName("head")[0].appendChild(s);})(document);</script><script data-minify="1" type='text/javascript' src='https://www.asktraders.com/wp-content/cache/min/1/wp-content/themes/asktraders/js/chunks/stickybutton.js?ver=1634635969' id='sticky-button-js' defer></script>
<script type='text/javascript' id='custom-js-js-extra'>
/* <![CDATA[ */
var ajax_script = {"ajaxurl":"https:\/\/www.asktraders.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script data-minify="1" type='text/javascript' src='https://www.asktraders.com/wp-content/cache/min/1/wp-content/themes/asktraders/js/custom.js?ver=1634635969' id='custom-js-js' defer></script>
<script type='text/javascript' id='t5b_widget-js-extra'>
/* <![CDATA[ */
var ajaxScript = {"ajaxurl":"https:\/\/www.asktraders.com\/wp-admin\/admin-ajax.php?wpml_lang=en"};
/* ]]> */
</script>
<script data-minify="1" type='text/javascript' src='https://www.asktraders.com/wp-content/cache/min/1/wp-content/themes/asktraders/js/t5b_widget.js?ver=1634635969' id='t5b_widget-js' defer></script>
<script data-minify="1" type='text/javascript' src='https://www.asktraders.com/wp-content/cache/min/1/wp-content/themes/asktraders/build/bundle.85da8529.js?ver=1634635969' id='theme-js-js' defer></script>
<script data-minify="1" type='text/javascript' src='https://www.asktraders.com/wp-content/cache/min/1/sdks/OneSignalSDK.js?ver=1634635969' async='async' id='remote_sdk-js'></script>
<script data-minify="1" type='text/javascript' src='https://www.asktraders.com/wp-content/cache/min/1/wp-content/plugins/optinmonster/assets/js/helper.js?ver=1634635969' id='optinmonster-wp-helper-js' defer></script>
<script>var FWP_HTTP = FWP_HTTP || {}; FWP_HTTP.lang = 'en';</script>		<script type="text/javascript">var omapi_localized = { ajax: 'https://www.asktraders.com/wp-admin/admin-ajax.php?optin-monster-ajax-route=1', nonce: '88853416e4', slugs: {"r9s6sovhqivbdwyvhtyr":{"slug":"r9s6sovhqivbdwyvhtyr","mailpoet":false},"drlldgfozy5ci0n5cbas":{"slug":"drlldgfozy5ci0n5cbas","mailpoet":false}} };</script>
				<script type="text/javascript">var omapi_data = {"wc_cart":[],"object_id":129245,"object_key":"news","object_type":"post","term_ids":[19270]};</script>
		<script>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</script>
<script>window.lazyLoadOptions={elements_selector:"img[data-lazy-src],.rocket-lazyload,iframe[data-lazy-src]",data_src:"lazy-src",data_srcset:"lazy-srcset",data_sizes:"lazy-sizes",class_loading:"lazyloading",class_loaded:"lazyloaded",threshold:300,callback_loaded:function(element){if(element.tagName==="IFRAME"&&element.dataset.rocketLazyload=="fitvidscompatible"){if(element.classList.contains("lazyloaded")){if(typeof window.jQuery!="undefined"){if(jQuery.fn.fitVids){jQuery(element).parent().fitVids()}}}}}};window.addEventListener('LazyLoad::Initialized',function(e){var lazyLoadInstance=e.detail.instance;if(window.MutationObserver){var observer=new MutationObserver(function(mutations){var image_count=0;var iframe_count=0;var rocketlazy_count=0;mutations.forEach(function(mutation){for(i=0;i<mutation.addedNodes.length;i++){if(typeof mutation.addedNodes[i].getElementsByTagName!=='function'){continue}
if(typeof mutation.addedNodes[i].getElementsByClassName!=='function'){continue}
images=mutation.addedNodes[i].getElementsByTagName('img');is_image=mutation.addedNodes[i].tagName=="IMG";iframes=mutation.addedNodes[i].getElementsByTagName('iframe');is_iframe=mutation.addedNodes[i].tagName=="IFRAME";rocket_lazy=mutation.addedNodes[i].getElementsByClassName('rocket-lazyload');image_count+=images.length;iframe_count+=iframes.length;rocketlazy_count+=rocket_lazy.length;if(is_image){image_count+=1}
if(is_iframe){iframe_count+=1}}});if(image_count>0||iframe_count>0||rocketlazy_count>0){lazyLoadInstance.update()}});var b=document.getElementsByTagName("body")[0];var config={childList:!0,subtree:!0};observer.observe(b,config)}},!1)</script><script data-no-minify="1" async src="https://www.asktraders.com/wp-content/plugins/wp-rocket/assets/js/lazyload/16.1/lazyload.min.js"></script><script>function lazyLoadThumb(e){var t='<img loading="lazy" data-lazy-src="https://i.ytimg.com/vi/ID/hqdefault.jpg" alt="" width="480" height="360"><noscript><img src="https://i.ytimg.com/vi/ID/hqdefault.jpg" alt="" width="480" height="360"></noscript>',a='<div class="play"></div>';return t.replace("ID",e)+a}function lazyLoadYoutubeIframe(){var e=document.createElement("iframe"),t="ID?autoplay=1";t+=0===this.dataset.query.length?'':'&'+this.dataset.query;e.setAttribute("src",t.replace("ID",this.dataset.src)),e.setAttribute("frameborder","0"),e.setAttribute("allowfullscreen","1"),e.setAttribute("allow", "accelerometer; autoplay; encrypted-media; gyroscope; picture-in-picture"),this.parentNode.replaceChild(e,this)}document.addEventListener("DOMContentLoaded",function(){var e,t,a=document.getElementsByClassName("rll-youtube-player");for(t=0;t<a.length;t++)e=document.createElement("div"),e.setAttribute("data-id",a[t].dataset.id),e.setAttribute("data-query", a[t].dataset.query),e.setAttribute("data-src", a[t].dataset.src),e.innerHTML=lazyLoadThumb(a[t].dataset.id),e.onclick=lazyLoadYoutubeIframe,a[t].appendChild(e)});</script></body>

</html>

<!-- This website is like a Rocket, isn't it? Performance optimized by WP Rocket. Learn more: https://wp-rocket.me - Debug: cached@1634917452 -->